Dell 600m No Longer recongizes AC adapter

Closed
cloak Posts 1 Registration date Thursday March 12, 2009 Status Member Last seen March 13, 2009 - Mar 13, 2009 at 03:11 PM
 lawrenceoflosangeles - Sep 2, 2009 at 12:58 AM
Hello,

My Dell Inspiron 600m, has been working fine. A few nights ago, the red low battery warning was solid. I plugged it back into my new AC power adapter which is only a few months old and working. The green LED is lit on the adapter, but the battery will not charge and the computer will not power on from the AC adapter.

I don't have enough battery power to run a diagnostic. I did try checking the two memory modules, but that did not change anything.

Is this a problem with the power jack or charging circuit?
Any ideas?

Thanks,
C

2 responses

lawrenceoflosangeles
Sep 2, 2009 at 12:58 AM
I have had this issue with a number of Dell 600 and 600m laptops. It is a problem with the motherboard which will not detect when an AC adapter is plugged into the laptop.

The best workaround short of replacing the motherboard is to purchase a Dell docking station and a 90w Dell power supply (if you dont already have one; a 65w power pack will not work with the docking station). You can find them on ebay for pretty cheap, 20.00 for the dock and 30.00 for the 90w power pack.

The docking station works well to charge the laptop.
hotpurs Posts 14 Registration date Saturday October 11, 2008 Status Member Last seen May 14, 2009 2
Mar 15, 2009 at 02:31 AM
hi,
try another charger to see if it works.
it may be a problem in te jack.
take the charger to where you bought it and get it replaced.