Removing write-protect - nothing works

[Closed]
Report
-
 Philip -
I have looked at dozens of websites on the internet that give advice for removing the write-protect from a usb stick. I have tried everything, and absolutely nothing makes any difference. I still get the message 'this device is write-protected'. This is a 32 GB memory stick and I have Windows 8. It seems that this is a waste of good money. There was no indication when I bought it that it was write-protected. What can I do?

1 reply

Posts
275
Registration date
Friday October 10, 2014
Status
Member
Last seen
October 19, 2016
35
Hey there, Philip.
If this is a new USB flash drive as implied from the post and you've tried everything to remove the write protection (registry edit option, diskpart, any switches on the flash drive itself etc.), then there's not much you can do. You can try downloading some of the manufacturer's formatting tools, which the offer for their devices, to see if you'll be able to reformat it. Other than that, if that doesn't work as well, I'd suggest that you go and get it replaced.

Hope that helps.
Boogieman_WD

WD Representative
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

Thanks for this. I've searched the Novatech website but can find no mention of formatting tools.