Windows 7 can not access usb hard drive but dos can.

[Closed]
Report
-
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
-
Hello,

I have a Samsung portable hard drive that windows can not access. It sees the drive but when I click on it I get the error "E:\ is not accessible, Access denied"

If I launch a cmd prompt I can see and access the drive. I've used chkdsk /f & /s to no avail. I've also tried to change permissions but that doesn't work either.

I've also plugged the drive into another computer with the same results. Chkdsk did find some errors and repaired them but still didn't work.

I am also able to xcopy files from the drive to my hard drive but would really like to use Windows instead of old school DOS.

Any ideas?

2 replies

Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
110
Hello Jeremy,

Please, follow these steps:
1. Open command prompt
2. Type the following: attrib -s -h -r X: /*.* / s / d Then hit "Enter" and wait about 30 seconds Be careful! Respect the spaces between words and script. Change the letter X with that has been assigned to the SD card on your PC (that you can see it in My Computer. It can be anything, depends on each computer)
3. Finally, browse the flash drive and delete the "RECYCLER" folder and if there is another one called "Autorun" you have to delete that too. You could also try opening your SD card with data recovery software.
Make sure that you have full control over the folders so that you can change the attributes. In order to have it try the mentioned command when you start your PC in Save mode, meaning you have to open it as an administrator. If it doesn't work, then you could try the following options:
1. Right-click the flash disk shown in My Computer and select Properties> Click on the Security tab>Click Advanced in the lower right.
2. In the Advanced Security Settings window that pops up, and after that click on the Owner tab>Click Edit>Click Other users or groups>Click Advanced in the lower left corner>Click Find Now.
3. Scroll through the results and double-click on your current user account.
4. Click OK to all of the remaining windows except the first Properties window.
5. Select your user account from the list up top and click Edit.
6. Select your user account from the list up top again and then in the pane below, check Full control under Allow, or as much control as you need. You'll get a security warning, click Yes.

Good luck and come to share if that worked.
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

Thanks for the help. I actually figured out what the problem was. It looks like certain user names like Everyone, User, Administrator were stripped from the drive under the Security Tab for properties.

I plugged an identical hard drive in to see what users / groups were assigned and noticed several missing from the drive with access issues. So if anyone else has a similar problem hopefully this will help.

Cheers! Jeremy
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
110
Great, thanks for the update! :)