Amilo Pi adaptor problems!!! :(

Closed
thancho
Posts
9
Registration date
Saturday March 28, 2009
Status
Member
Last seen
June 16, 2009
- Apr 6, 2009 at 06:40 AM
ham.let84
Posts
6
Registration date
Saturday March 7, 2009
Status
Member
Last seen
June 8, 2009
- Apr 6, 2009 at 09:21 AM
Hi guys

My girlfriend owns a Amilo Pi she''s had for about 2years and never had any major issues with it.

But in the recent month or so theres been quite serious problem. The charger connector (the metal/plastic bit that connects charger and laptop) gets very very hot touch it and you get slight burnt! The charger tip has had to be changed the plastic had melted and smelt burnt after awhile. So the tip''s been changed and the the overheating tip is still an issue. The tip has overheated again it has melted inside the laptop socket and has heat to such a heat that the tip (and the cable) is stuck/melted inside.

The laptop it self seems to be working well and quite hot but with the norm (I think). Its just the charger connector tip that''s the problem.

Any help guys!! Please!!
Could it be the charger not working correctly? The laptops PSU not up to scratch? Bios problem? ... I don''t want the laptop to stop working altogether!!

PS. the laptop was bought in Spain and we''re in the UK (if that''s a possible problem). Battery life isn''t great. Already cleaned the laptop with compressed air and have the fans with good access to air (the laptop is on "stilts").

1 reply

ham.let84
Posts
6
Registration date
Saturday March 7, 2009
Status
Member
Last seen
June 8, 2009
3
Apr 6, 2009 at 09:21 AM
hi,
it may be that there is a short circuit problem with the power supply. (in the connector itself).
get the power supply replaced to see if the problem continues.
check if the input power requirement for the charger matches that of your country.
0