External hard drive copy slow issue

Closed
Alfred - Jun 11, 2016 at 09:03 AM
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 - Jun 11, 2016 at 02:57 PM
Goto: Device manager/Disk Drives
Find the disk and right click for properties option.
Click 'Policies' tab'
Check "Better Performance"

Even i follow this instruction ABOVE it still doesn't work.
I've already disable my firewall too.
Are there anyone facing the same issue like me??
Related:

1 response

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,825
Jun 11, 2016 at 02:57 PM
What version of windows are you using and what is the make and model of the PC?

Early versions of USB (1.0) are vary slow and there is nothing you can do about it. USB 2.0 is still slow. It's only when you get to USB 3.0 that you have somewhat good write speed.