Seagate expansion hd with flashing blue light but not deducted.

Closed
D_arun
Posts
1
Registration date
Monday January 16, 2017
Status
Member
Last seen
January 16, 2017
- Updated by D_arun on 16/01/17 at 10:57 AM
R2D2_WD
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
- Jan 18, 2017 at 04:17 AM
Hi I'm arun.

I have bought seagate expansion 1tb hard disk 3 years back i used less than 20 times. I just used to save my pictures n songs after all i never used it so long years never even connect to the pc. Today i tried to connect the hard disk to recover my old pictures the hard disk wont show up on my laptop.

1. Hard disk with bliking blue light.
2. I can feel the vibration on it.
3. I tried to find drive in disk management couldnt find.
4. Device manager also couldn't find n others category.
5. I tried with it other 3 desktops the same signs.
6. I followed the many instructions which is shown in youtube n all no use.
7. Warranty ofcourse expired.
8. All ports working perfectly even i tried to update usb drivers its all up to date. Mouse n other thump drive working fine in it.


Kindly anyone help me reterive my picture back.
Thanks in advance.

1 reply

R2D2_WD
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
152
Jan 18, 2017 at 04:17 AM
Hi D_arun,

You have done really good job trying to solve the issue. If the drive is not listed in Disk Management and you have tested it on multiple PC and the drive is still not recognized, there may a problem with the device. It is hard to tell what is going on, but I would advise you to connect it to a Linux PC. Sometimes UNIX based systems show better results recognized drives with connectivity issues. If you have no access to a Linux PC, try using a Linux Live CD version. You only need to boot from it, no installation is required.

Hope this helps

0