No signal on monitor, PC shuts down instantly [Solved/Closed]

- - Latest reply: Ambucias
Posts
51376
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
October 29, 2019
- May 13, 2017 at 05:39 PM
Hello,

When I try to turn on my desktop computer, all lights turn on and the fans are working but the monitor displays "no signal". If I press the button On/Off, the computers shuts down instantly. This computer worked perfectly Yesterday, it was shut down normally, I didn't move it.

If I unplug the VGA port, the monitor displays a message "please check cable connection" but it displays "no signal" when it is plugged. I don't have better results with the HDMI port with a TV screen. I have tried to reseat all internal connections, I have unplugged the RAM module and plugged it on the other port, I have replaced the CMOS battery. I have replaced the SATA cables by other working cables. I can hear the hard drive working when computer is turned on. I have tried to connect the hard drive to SATA 0 to 3 on the motherboard. I tried to boot on a liveUSB : it is recognized (blinking light) but the computer doesn't start on it. I have cleaned all dust particles.

None of the above gave any satisfying result... As my motherboard has no speaker, I don't have the luck to hear any beep signal. Do anyone have any suggestion about how to repair it?

Thank you in advance for your help,
Ray.
See more 

2 replies

Best answer
1
Thank you
I've finally found the solution, so here is the explanation in case someone else gets the same issue:

I noticed that I have 2 VGA ports on my computer: the cable needs to be plugged in to the graphic card VGA port, not to the motherboard: otherwise, there is no signal. My computer turned down immediately after pressing On/Off button because after replacing the CMOS battery, the BIOS was reseted and it asked what to do about it: reset default and restart or reset default and continue boot. As the BIOS didn't even launch, the computer directly shutted down when button was pressed. As soon as I had access to a signal on my monitor, it was easy peasy to correct. Finally, the initial problem came from a windows update (I didn't remember it updated last time I used it) that went wrong. A little restoration and voilà, brand new!

Good luck to anyone having the same problem.
Bye!

Say "Thank you" 1

A few words of thanks would be greatly appreciated. Add comment

CCM 5922 users have said thank you to us this month

Posts
51376
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
October 29, 2019
13220
0
Thank you
Thank you very much for getting back to us. In the long run you have been very helpful.