Report

Lenovo Z51-70 model model 80k6 won't turn on [Solved/Closed]

Ask a question Mountpotato - Last answered on Mar 4, 2016 at 05:45 PM by Ambucias
Hello,
Last night I accidentally drained the battery fully ( it gave me 7% low battery sign, but I wasn't able to charge it) so it turned off, and I was too tired to charge it, so the next morning I tried to charge it, it worked, but when I tried to turn it on it won't power on.

One of my friends told me I probably fully drained the laptop's battery, and I should just leave it to charge overnight, which was probably correct because the charging light went from amber red (blinking) to a steady white light ( which in the manual

says the battery power is over 80%, but still when I try to power it on, it still won't work.

i still have its warranty, and I just bought it a little less than over 4 months ago, which is sad, are lenovo laptops this faulty?

Anyways, is there anything I could do for now to speed up the process of it being fully charged?
or maybe this is even a different case, and my laptop broke?

Lenovo z51-70
Model : 80k6
See more 
Helpful
+0
plus moins
Hi Mountpotato,

This is usually not a fault as such, but caused by some residual charge being "in the wrong place" to allow boot up. Please forgive the bad (wrong) description, but its the best I can do at 01:50 in the morning.

Try removing the battery completely and removing the charger. Now press and hld the [ON] button for about 30 seconds. Replace the battery and swich it on normally.

Please let me know how you get on.
Mountpotato 2Posts Friday October 30, 2015Registration date October 31, 2015 Last seen - Oct 31, 2015 at 03:44 AM
So I tried to open it up,since the battery is inside,but unfortunately I couldn't open it since I didn't know how, and there are no tutorials in youtube for my laptop on how to get the battery out. is there any other way?

and opening it up and removing the battery. wouldn't that make the warranty void?
BrianGreen 907Posts Saturday January 17, 2015Registration date ModeratorStatus April 24, 2017 Last seen - Oct 31, 2015 at 07:42 PM
Hi Mountpotato,

Yes - I didnt realise you had to unscrew things on this model. I would recommend against removing the back, and if needed take it back to the shop.

However, there is also an "Advanced" sleep mode that your machine may have gone into. According to the manual for this machine you could try holding the power button for about 5 seconds and then if it doesnt come on try the power button as normal.

Good Luck - let me know how you get on.
Ambucias 41878Posts Monday February 1, 2010Registration date ModeratorStatus May 28, 2017 Last seen - Mar 4, 2016 at 05:45 PM
Wow! Another problem bites the dust, thanks to Brian, our senior citizen!
Ozzzyyyy- Mar 4, 2016 at 05:43 PM
Great this worked for me thanks!
Helpful
+0
plus moins
Thank you so much for the fast reply, ill be trying that in a bit, since my laptop's battery is inside itself and I still have to screw it open just to get it.

I'll have to find myself a small screw driver, then ill update you on what I get. Thanks so much for the fast reply mate, i've been up all night trying to figure this out, I hope it works, if so, you just saved me 1000$.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!