Unable to see files in external hard drive

sarahfaith1211 Posts 1 Registration date Sunday December 31, 2017 Status Member Last seen December 31, 2017 - Dec 31, 2017 at 12:29 PM
 Sarahfaith1211 - Dec 31, 2017 at 02:21 PM
I have an external 1 terabyte hard drive. It is a Western Digital Passport Essential SE 0740 USB 3.0 Device that I bought from Best Buy in I believe 2011. I am using Windows 10 64bit. When I plug it into the computer, the small white LED on the hard drive will light up and blink, showing that it is connected to the computer. It will also make the sound if I unplug the USB that it was disconnected, so I know the computer is recognizing it. However, it will not show up under “My Computer” so I cannot access the files. I have also tried plugging it into two different windows 7 computers, and my PS4 with the same result. I have tried using a different USB cable. I have tried restarting my computer with the hard drive connected. I have updated my computer to the latest update possible. I was last able to access this hard drive in 2015 on the same computer I am using now.

It has many family memories both pictures and videos from the last 10 years as well as some movies I had downloaded using the code you get when you buy the blu-ray/dvd bundle. This hard drive is the ONLY place I have the family memories and I am getting sick at the thought that they might be gone forever. I want to start using Amazon Prime Cloud service so that I do not run into this problem again. I don’t think I have more than 250gb of data on the drive.

I googled my problem and found that others have a similar issue, although I have not found one with quite the exact same problem as mine. They say to press the windows button +R and type “devmgmt.msc” When I do that I see the device showing up under Disk Drives with no errors. I have tried uninstalling and reinstalling it from there with no luck. Also, I read to press the windows button + R and type “diskmgmt.msc”, the hard drive shows up under Disk 1 as “unknown” and “not initialized”. It gives me a pop up saying, “you must initialize a disk before logical disk manager can access it and gives me two options, to either use the partition style of MBR (Master Boot Record) or GPT (GUID Partition Table) When I select GPT the error message says, “The specified disk is not convertible because the size is less than the minimum size required for GPT disks.” When I click MBR, the error message says, “The request failed to a fatal device hardware error”

So, is my last hope to retrieve the pictures to pay big bucks for a professional data recovery company to pull my files by sending in the drive? If so, what company do you recommend that is both trustworthy and reasonable? I could care less about the movies, I just want my family pictures and videos back. Thanks in advance for any suggestions!

1 reply

xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,829
Dec 31, 2017 at 01:48 PM
Good news is you failed to reformat the hard drive that would have erased the data. When you selected the MBR option and it got the "hardware error". This tells me the hard disk was probably dropped sometime in the past and was damaged. Your only option at this time is to send it off to a "data recovery" service to see if the can recover some or all of the data. Figure on hundreds of dollars for the service.

Good Luck
Dec 31, 2017 at 02:21 PM
Thank you for taking the time to respond. I will begin looking for a data recovery company.