Monitor turns off after a few seconds when plugging in VGA

Report
-
Posts
1830
Registration date
Monday November 25, 2019
Status
Administrator
Last seen
September 25, 2020
-
Hello,

Hey everybody, I received this monitor from a friend a few days ago and decided to test it today, he said there was a problem but he forgot what it was (he hasn't used the monitor in a while). The monitor is an old 20" HP 2009f, was a little dirty when i received it but i've cleaned it. Looks like the problem is when I plug in the VGA cable, the monitor would show the image for a little bit then go completely black, the power indicator on the power button is still on and it goes completely black. I clicked the 'Source' and it would say 'Check Video Cable' then turn black again, sometimes it would flash the image that's being shown by the pc but then that's it, it goes back to black again in just a few seconds. Can anyone help me out? There's a DVI-D port on the monitor, I don't have a cable for DVI but should I buy one and test it? Do you think that's worth the risk?

Thanks in advance guys! ????

System Configuration: iPhone / Safari 13.1.1

1 reply

Posts
1830
Registration date
Monday November 25, 2019
Status
Administrator
Last seen
September 25, 2020
2,596
Hello, if you've got another VGA cable to try on the monitor that would be a good idea so you can see if its the cable or the monitor itself.

You should be able to pick up a DVI cable fairly cheaply - so this would also be a good idea to try the second input port.

After doing that you will know whether or not it is the cable that is causing the problem, or if there is a bigger issue with the monitor itself.

Regards