Messenger does not remember my username [Solved/Closed]

bobby5193 - Jul 31, 2009 at 09:18 AM - Latest reply:  Bobby 10
- Mar 26, 2010 at 02:20 PM
Hello, whenever I turn off my computer even though I checked 'remember me' on my msn messenger, it does not remember, and when I turn on I have to write it again which is really annoying . what can I do?
See more 

31 replies

Best answer
Adam Johnson - Aug 14, 2009 at 06:14 PM
74
Thank you
After hours of messing around with RegEdit + Yahoo Messenger + Microsoft's Virtual PC I've found the problem and a solution to why apps like Msn Messenger suddenly can't remember their passwords anymore.

When Yahoo toolbar gets installed it sets the following registry value:

[HKEY_USERS\S-1-5-21-796845957-926492609-725345543-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
AppData = %AppData%

The problem here is AppData should actually be the following

AppData = %USERPROFILE%\Application Data

So when MSN or other apps that use that registry key go to save their data it gets lost.

So the solution is simple, run regedit and go to

[HKEY_USERS\S-1-5-21-796845957-926492609-725345543-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]

and set the value AppData to a data value of %USERPROFILE%\Application Data

Thank you, Adam Johnson 74

Something to say? Add comment

CCM has helped 1588 users this month

Thank You!
Thank you! You must be one smart programmer.
Thaaaaaaaaaaankssssssssss u r wonderfulllllllllllllllll
what is regedit? how to fix this problem ...explain more plz...
Been bugging me for ages thx ur good. Brill site as well.
26
Thank you
I'm not saying that Adam Johnson way is wrong,instead,he helped me,but I found that his way is hard to be under stand of so I recreate a better understandable answer.

1. Click START
2. Click Run
3. Type in regedit
4. Click HKEY_USERS
5. Click S-1-5-21-2000478354-790525478-725345543-1005 ( this one is more complicated , first you need to find the one without CLASSES at the back like this one : S-1-5-21-2000478354-790525478-725345543-1005_CLASSES. The one without CLASSES is the right one )
6. Click Software
7. Click Microsoft
8. Click Window
9. Click Current Version
10. Click Explorer
11. Click User Shell Folder
12. Right click on AppData and click Modify
13. Insert this name to value data -> %USERPROFILE%\Application Data
14. Close Registry Editor and you're done,all thanks to Adam Johnson.

Credit for Adam Johnson , thank you so much!!!!
Your solution actually made my comp worse..Now it cant remeber it password on anything on my laptop...it Earsed my password from skpe...yahoo .
Thanx alot it really works/
TheCoolMan9 38 Posts Monday July 27, 2009Registration date October 21, 2009 Last seen - Jul 31, 2009 at 09:57 AM
5
Thank you
i am happy you asked because I am having the same exact problem
TheCoolMan9 38 Posts Monday July 27, 2009Registration date October 21, 2009 Last seen - Aug 17, 2009 at 05:44 AM
2
Thank you
thanks alot dude
Thanks A lot it's solved.
2
Thank you
thanx, Adam^^
hi guys, read all this with interest because I have same issue, but like one other in the list I do not have this file.

when I open the user shell folders all I have is a foulder called new, nothing else, so how do I solve this now?

an ideas? this is bugging the hell out of me having to sign in every time.
aqeel > swampy206 - Jan 13, 2010 at 12:43 AM
For those who say they dont have this key. actually they have it. Infact you dont need to click on the + sign with "user shell folder", because when you do this, it will show the folder inside it which is "new". if you click on the "user shell folder" button itself, then it will show all the keys in the main explorer window. thanks to johnson.
2
Thank you
thanx yo. yo r awsome
truelements - Aug 31, 2009 at 09:01 PM
1
Thank you
well that look like it could help but my laptop doesn't anything of yahoo installed. At lease that I know of.
my laptop brand is an Acer one.
1
Thank you
thanx dude ure a lifesaver!
U r a gift from Heaven. 1000000% working ;)
1
Thank you
Mine does not work either :O sooo annoying ...
1
Thank you
Nice MAN
0
Thank you
Hiya there,

Your solution does work.

Thanks alot...
-1
Thank you
same problem over here....
And nobody is knowing the answer...
MICROSOFT MSN SOCKS