My Windows XP not recognize any memory device

Dario - Aug 5, 2008 at 08:33 PM
 thestonecrusher - Nov 9, 2012 at 01:51 PM

My Windows XP not recognize any memory devices (installed on my notebook Acer 4720), like pen drives, memory cards, etc... I tried a lot of things to solve this problem. Can somebody there help me?


42 responses

I know this post is old already, but if it may help any new commmers.

I did this once with one of my USB flash drives. The way I fixed it was by reformatting it with either the ntfs or the FAT partition. Try this:

1. insert the flash drive into usb port
2. right click on "My Computer" > Manage - The Computer Management window popsup.
3. Select Disk Management
4. Locate your Flash Drive at the bottom where it starts with "Disk 0" which is your Hard Drive.
5. Your Flash Drive should say something like "Disk 1, removable", to the right it should have a blue line which means it's a primary partition.
6. If it has a Black line, then it means that the Flash Drive has not been partitioned. To fix this do this:
7. Right click on the black line. It should give you an option to partion it.
8. Go ahead and partition it to FAT or NTFS which ever option you can get or want.
9. Once it is finished, then you will be able to read and write from the Flash Drive.

Let me know if it does not work or if you are having problems.
Bingo!!!!!!!!! thanks

I think this is to do with backup. I got "disk full" when backin up 11Gb to a 16Gb USB drive.
Can you help?
I checked our removable harddrive on my mini notebook and it works and I checked the stuff as you wrote and it does appear with the blue line but if I plug it into my pc, it doesnt show anything blue or black line. Any adivce?
You are a legend Johnny Thanks very much worked a treat !!!
hey I did all the things you recommended to do.but when I loctate my USB and click on it..the blue line dosent appear..its just empty with nothing that appears on it
Jhonny thnxs so much, all I did was format this weird device from asia and now it FINALLY works. thnx a whole lot!!!!!! <3
Hi. I've got a problem with my flash drive. I have a Dell desktop with Windows XP. Yesterday my SanDisk Cruzer 2.0GB flash drive worked fine, and last night it stopped. It's not full, since a month ago I got rid of a bunch of stuff. It's not the PC, since I checked it on another PC. I insert it into the USB port(s) and the light goes, but the PC is not even recognizing that anything is in it, and no drives show up when I go to My Computer. I am NOT interested in reformatting...I have information on that drive I need. Any links, steps, software, etc. that might help me to get the PC to read the drive again, and for me to access the flash drive to save the info, would be greatly appreciated.
I was having the same problem. Went into Device manager, USB contorllers and deleted the USB Mass Storage Device listed there. Plugged the flash drive back in and Roberts your Father's Brother!
Thanks! This has solved a very frustrating problem for me.
I've tried everthing but nothing seems to work!

Yesterday the computer was fine and recognised the SD card with no problems! Now the light won't even turn on!

What's wrong with the damn thing!? :)

In 'Computer Management' I only have 'Disc 0' which has a blue line across the top, 'Disc 1' (I) which has nothing next to it and also 'CD-ROM 0' and that's all folks!


This totally sucks!

Didn't find the answer you are looking for?

Ask a question

I've had this problem for about a week on my laptop with XP. USB flash memory that I have used before and contain data were suddenly unusable on my system yet worked on other computers. All I got was a message that the disk was not formatted. Reformatting failed which was a good thing as all data would have been lost.

It's a glitch in service pack 3. I finally resolved the problem by rolling back XP service pack 3 to SP2. Doing that was quite tricky at first as the add/remove programs function didn't allow sp3 to be removed. The work around is simple. This from Microsoft site:

1. Click Start, click Run, type c:\windows\$NtServicePackUninstall$\spuninst\spuninst.exe in the Open box, and then click OK.
2. When the Windows XP Service Pack 3 Removal Wizard starts, click Next.
3. Follow the instructions on the screen to remove Windows XP SP3.

Reboot and you're back to SP2 and your flash drives, USB devices will run as normal.

Sorry if you have Vista cause I haven't got a clue
hi..i have portable usb 500gb hard disk drive..i'm using win xp sp3..till one week ago the hard disk was working fine..then from no reason when I plugged it in the windows found the new hardware but didn't recognize it as a hard disk and wanted the drivers for it..and this hard drive doesn't need other 2gb ub disc and mp3 players work fine when I connect them in the usb..i tried reinstalling windows,reinstalling usb drivers, changeing the usb kabel and nothing works..
when I plug in the hard drive in other computers it works just fine..
now I really don't know what to do..
thx for helping
hi friends in my pen drive I have a problem like ..
pendrive is detected but I can.t open response id please insert disk whenever I plug it

any one can help out me

I've got the same problem, all my external removalable storage is recognised by Win Xp but it doesn't read the format (FAT or NTFS). All the drives work correctly on ofther machines so its something wrong with my OS. Anti virus scanners come up with nothing (but can read any attached removable drives pre-windows boot but not after windows is booted).

I've tried uninstalling all USB drivers and reinstalling them - didn't fix the problem

I'm at a loss at what to do short of reinstalling windows (but I'm currently travelling around india so that v.difficult). The drives all aare full off photos so reformatting them isn't an option (although the formatting is fine anyway as they work on other computers).

Any suggestions would be hugely apperciated. In short, the drives are fine, but there is an issue with windows reading the format of the drive. Is thefre a conflict going on somewhere?

i had a similar issue, and the problem was a conflicting windows update. I have no idea hwo to fix these bloody things but I had log in and fix it.. much easier and CHEAPER than Geek Squad or the like
OK here is my situation.

All of my external media device(iPod, 4GB SD, .5TB, 2GB) thumb were working fine. Then every time I plug them into my computer it won't regognize them and says they need to be formated.

I used another computer to backup and reformat the thumb drive and now it works fine on my computer.

Now that I have done this when I am looking at the computer managment screen it show the thumb drive as NTFS and then below that it says Healthy (active, primary partition) and the area behind that is all white(sorry don't know any other way to describe this).

But the 4GB SD that I have not formatted on another computer shows like this on the computer managment screen. It says RAW instead of NTFS and below says Healthy( primary partition) and the background has diagonal blue pinstripes behind this information.

I have info on the .5TB that I can not lose and have no way to back it up(stuck in Iraq) because of where I am for the next 6 months.

Any help here? Hope this will help some others on here too.

thanks for the advice,,I was able to reformat my flash drive.

I really appreciate it.

This answer may not help all of you, but it helped me.

My external SanDisk Cruzer flash drive wasn't being read.

I tried most of the stuff already mentioned...Tweak, resetting, etc. Tried another PC, took the flash drive to a local shop, tried to re-load the drivers, contacted the SanDisk site and did all their suggestions...all to no avail. The guy at the local PC shop said as long as the light on the disk flashes, there's power, and to just keep trying. I tried pulling it out and sticking it back in at random times for a week. Nada. Then, one time, the PC was able to recognize the pictures on the drive, but the U3 system still didn't boot up. Kept trying. A few tries later U3 came up, and I was able to transfer some, but not all the data. It took a few more days, but ultimately it came back up enough times so I could transfer all the data before it crashed again.

So, if the light is working, keep trying!
My problem was solved when I realized that my laptop has some security encryption software installed on it (to protect the hard drive if the machine is stolen).
This software has an option to disallow access to unencrypted media - and this option had reset itself so this feature was turned ON.... hence any USB memory stick or external hard disk I plugged in that wasn't encrypted with the same software became 'invisible' to the laptop.
A little right-click and a tick in the right checkbox solved the problem.
Arrgh. All those wasted hours.....
Gregga // animal > PeteS
Apr 10, 2009 at 03:30 AM

Try reformating derive letter from F: to something else!!

That worked for me dude!

later shreds!
Guillermo > PeteS
Jul 8, 2009 at 03:27 PM
PeteS, I am having the same problem! please can you provide some details on how you solved it?

Thanks and regards
VictorTim > PeteS
Jul 17, 2009 at 11:14 AM
Hi Pete, could you also send me details on how to adjust encryption settings, this problem is killing me. I cant find anything anywhere.
I am having the same problem (usb drive shows up as drive F, but when I try opening it, it asks me to format the drive; and the drive works fine on other computers). You mentioned security software on your pc - which security software was it, and how did you turn it off?

EKR Mail me ask Questions at
Apr 29, 2009 at 04:20 PM
This is the Problem of Flash Drives!
1.) This Won't work Window 95&98
2.) It only Works Windows 2000/XP/Vista
3.) The Very important thing is if you don't do
"Safe or Remove Devices" to your device if will courrupt
and can't use it no more or you can scan using scandisk
to do that plug your flash drive and go to my computer right click
to Removable or Flashdisk & go to tools and scan automatic fix errors
4.) if it does not appear then ask me I Know alot about Flash Drives
and Hard Drives that how to format! or Recovery!
"Please send me a messege if you have questions!"
Hey my sandisk cruzer 4gb wont work.i plug it in my desktop and light comes up then goes out. I had it in my laptop for a minute to transfer songs last time it worked. my laptop has vista and my desktop has xp. I took it out after moving songs now it wont work. any thing I can do to fix this?
Right Click the in My Computer Go to Manage And Disk Management U Can Format there
I tried what you said and it was formatting much quicker, once it said 100% it said "formatting could not be complete" Any suggestions?

Thank goodness for these forums! I just ran into the same problem and the TweakUI fix worked for me. My PC had not been connected to the internet for several years since I had access at work. I would use a flash drive to bring home anything I wantged to save electronically. Now out of work and need the intertnet for effective job search. Got hooked up and ran Windows update since I wasn't bothering with updates while I was not connected on the PC. First time I plugged the flah drive in, it wouldn't work properly. I could not see it under "My Computer" but could find it in device manager. However I couldn't open files directly, has to copy to my C drive, then open them. I am certain it was an update conflict as last poster mentioned.

When I used TweakUI, all 26 drive options were checked so I unchecked all but C and D (D is my DVD drive), then clicked "Apply". It hung but after 5 minutes or so, I closed with Task Manager, reopened app and checked A (diskette) and F (USB port) then "Apply". It hung again and after 5 minutes I closed with Task Manager BUT my registgry had been updated and the device is recognized and can be accessed in the usual manner now.

Thanks to all who posted. Try this approach!
I had same problem (Windows XP saying none of my USB memory sticks were formatted even though they contained data that was readable on other PCs). It occurred after Windows decided to run a chkdsk /f on start up. I think a driver file got deleted. I copied the contents of C:\WINDOWS\System32\drivers from an identical PC at the same Windows update level - (network the PCs together, select all, copy, then paste but avoid overwriting any files by holding down SHIFT when you click on NO to overwrite so it just copies files that aren't on the target PC).
I then rebooted the target PC and it could once again read my USB memory sticks.
So, I'm afraid I don't know exactly which driver is missing but I think this may be your problem.
I have been completely unable to use my, obviously fake< Sony vaio 64 Gb stick, the computer wants to format it all the time, be then cannot do it anyway.
On my ACER laptop it worked fine at first, but after the attempts to format on the XP set, it didnt want to know it any longer until I accidentially asked the laptop for a QUICK format and almost instantly, it was formatted and works fine, but thats a VISTA setup,.... it still refuses to work on the XP

Go figure.....................
I think this problem can be solved by checking the error of the drive by right clicking on the removable drive drom my computer then click on the properties then tools the click the button check now. this will automatically check the errors on the drive and also rectify if any problem had.

It's worse than's a SanDisk 2.0 GB and I've gone to the website and tried to download the U3 program...SanDisk is telling me my flash needs to be a SanDisk product...something has corrupted it all to H*ll...guess I'll try the Geek Squad or something.

You ain't kidding about Smith-Corona...every time I have one of these horrendous IT experiences I'm reminded of the simple days of the 80s and 90s...LMAO
problems solved
Jun 17, 2010 at 08:32 PM
if u run certain antivirus software like avg (malware) then when u plug your jump sticks with illegal "things" on it then "certain " antivirus software corrupts the reg so the jump sticks wont work and do very funny things such as most of your problems, wont recognize, must format now etc etc the only real way to fix is reinstall how to tell if this is the cause your system wont recognize or does funny things but other computers don't have an issue with the stick