Wireless connection issue

[Solved/Closed]
Report
-
Posts
1
Registration date
Friday December 18, 2009
Status
Member
Last seen
December 19, 2009
-
Hello,

I have a small office system at home:

A.) PC (XP) DHCP - Wired
B.) PC (W7) DHCP - Wired
C.) Laptop (XP) DHCP - Wired/Wireless
D.) Laptop (XP) ?????? - Wireless
E.) ADSL Router
F.) Switch

So all wired devices A,B,C,E connect to the Switch, so there's internet access on all of them.

Laptop "C" and Laptop "D" already have a working connection in the sense of Wireless going (Laptop to Laptop WPA AES with SSID etc).

Now I want to connect Laptop "D" wirelessly to Laptop "C" so that Laptop "D" also has internet access AND access shared resources on "C". I tried sharing the LAN connection on "C", then assigning static IP to "C" WLAN connection. But somehow I dont get the IP's, the gateway or the DNS address right on both "C" and "D" to make this work. I used 192.168.0.1 on my WLAN "C" connection as IP.

Any ideas and solutions are very welcome ; including gateway IP suggestions and so on.
If it might help, my LAN wired connection is 192.168.1.xx with the ADSL router being 192.168.1.1 and as i've said before i set laptop "C" on static to 192.168.0.1.

1 reply

Posts
1
Registration date
Friday December 18, 2009
Status
Member
Last seen
December 19, 2009

Solved this issue on my own after hours of suffering. The issue was not the IP configurations, all settings were correct :

gateway settings;
"D" -> 192.168.0.1 "C" (WLAN IP of "C") "D WLAN" with automatic IP 192.168.0.xx
"C" -> 192.168.1.4 "C" (LAN IP of "C") "C WLAN" with static IP 192.168.0.1 , "C LAN" with DHCP 192.168.1.4
"C" -> 192.168.1.1 "E" (LAN IP of "E") "C LAN" with DHCP

I could ping various sites through "D" but could never have any HTTP connection in a browser so the issue was resolved by changing the WPA setting on the Wireless setting to WEP with network key. Re-creating that with WEP instead of WPA on Laptop "C", then connecting to it with Laptop "D" gave instant internet access with settings mentioned above.

But anyway, thanks for helping :D