Page cannot be displayed msg in IE & Mozilla [Solved/Closed]

Reshmi 2 Posts Friday September 5, 2008Registration date September 6, 2008 Last seen - Sep 6, 2008 at 02:53 AM - Latest reply: benjasmine 1 Posts Friday December 5, 2014Registration date December 5, 2014 Last seen
- Dec 5, 2014 at 05:17 AM

I have got a problem with my system. The Internet Explorer was working fine, but suddenly yesterday for any url
provided in the browser window, it shows 'Page cannot be displayed'. Am not able to browse any pages. Am providing the right URL only. When am trying to login to my yahoo msgr it works perfectly alright. Only problem is with the browser.

I tried the following

---> Setting the Windows Security settings to default,

---> Checking the network connections.

---> Tried downloading Mozilla and tried browsing from that, to know whether the problem is with IE, but the same problem exist with Mozilla too.

My OS is Windows Vista.

Please guide me on what I need to do.
See more 

84 replies

Best answer
Thank you
You guys could try the following to bring back the browser service, if it's not a connection or dns issue:

1. in the cml run "regsvr32 actxprxy.dll" and "regsvr32 shdocvw.dll"

2. reboot windows

If the above couldn't fix the issues, run the following extra commds:

regsvr32 mshtml.dll
regsvr32 urlmon.dll
regsvr32 msjava.dll
regsvr32 shdocvw.dll
regsvr32 browseui.dll
regsvr32 actxprxy.dll
regsvr32 oleaut32.dll
regsvr32 shell32.dll
and restart the system once again

Thank you, fangnyang 22

Something to say? Add comment

CCM has helped 1839 users this month

I am still curious, however. What causes the problem in the first place? It just seem to occur without any specific cause.
marsea 4 Posts Wednesday January 7, 2009Registration date January 8, 2009 Last seen - Jan 8, 2009 at 10:39 AM

what is ''cml'' how do I get there to type in 'regsvr32 actxprxy.dll'
happypappyh72 > marsea 4 Posts Wednesday January 7, 2009Registration date January 8, 2009 Last seen - Nov 16, 2009 at 08:57 AM
Page cannot be displayed
marsea 4 Posts Wednesday January 7, 2009Registration date January 8, 2009 Last seen - Jan 8, 2009 at 10:51 AM
you are a genius fangnyang...I am so happy you helped us...thank you so much...:))))
Hi Fangnyang,

Could you possibly be so kind as to email me what you posted regarding the problem. I have tried to print your reply to others so that I could try it and for some strange reason it will only print responses on above posts, like the first page. I too have had this problem of the error displayed and no browser on Mozilla Firefox. I found that once I shut down computer the problem ceases. HOWEVER today it happened 3x and I am unwilling to continue. Previously it only happened once a week ! UUGGH! Thanks for your help !

Thank you
I finally got my problem resolved!

Someone on another forum (computer net) suggested that I set IE and Firefox to accept no proxy from the net to bypass any spyware/virus that redirects links.

For IE:
In the browser, go to "Tools', 'Internet Options', "Connection", "LAN Settings" and uncheck all the boxes.

For Firefox:

In the browser, go to "Tools", "Options", "Advanced", "Network", "Settings" and check the "Direct connection to the Internet" button (leave all other buttons unchecked).

Hope this works for whoever else is having the same problem!
AJ - log on to: This is an article I recently found regarding the fix for mozilla. Maybe it will work for you. Good Luck
Hi Chris and TexasIT, i've already have this problem yesterday
i spent my wholeday to find out, until I find this post today

i use win8 with IE 10
I've tried to uncheck SSL 3, and checklist TLS 1.0, 1.1, 1.2 , buat still cannot access facebook / yahoo / google, buat I can access bing, and some other website
It also happened with mozilla, same with IE
And it caused Yahoo messenger cannot login too because it depends on IE access
But my chrome can access all websites without any problem

Anyone can help me please

thank you for your help
Thank you so much! Ive just spent3 hours trying to get my laptop to work so my little girl can do her homework tomorrow online
Chris, thank you so much for the my friends computer to open FB with the first try after following your instructions.......very cool......
benjasmine 1 Posts Friday December 5, 2014Registration date December 5, 2014 Last seen - Dec 5, 2014 at 05:17 AM
Just want to share my experience here...

I'm using IE 11 on Win 7.

Few months ago, I noticed that I couldn't access Tumblr on my PC. I was like... Fine, I can live with that and didn't bother...

Few days ago, I couldn't access Google and Gmail any more. This time, I entered panic mode...

I spent hours and tried just about everything... enable protected mode, reset all settings, revert back to IE 10 an 9 by removing updates, system restore, scan my computers with multiple tools for virus and malware, etc.

Nothing worked until I did one simple thing -- uncheck TLS 1.2 ! It was just that simple, at least in my case.

Not only can I access Google and Gmail now, I can also access Tumblr, which stopped working for me few months ago.

I don't know why it worked. Can someone explain this?
Thank you
I was experiencing similar problems, here is what I did to fix, give it a go and let me know if you have any success.

the problem for seemed to be that some of the services that windows was running were falling over (I'm using XP by the way). Restarting these seemed to do the trick.

+ Open 'Run' from the Start menu and type in 'services.msc'

Find the services "Wireless Zero Configuration" and "DHCP Client" in the window that opens.

+ Right click on 'Wireless Zero Configuration" and select Restart. Once it has restarted, do the same for "DHCP Client". Try opening your browser again and open a webpage. It should now work properly.

Now a bit of a problem was every time I restarted my PC I had to repeat the process. I setup a batch file to run during startup so I didn't have to worry about doing this.

+ Create a file called "srestart.bat" anywhere you like. Edit it and but the following lines in:

@echo off
net stop "Wireless Zero Configuration"
net start "Wireless Zero Configuration"
net stop "DHCP Client"
net start "DHCP Client"

Now go into Control Panel and open Scheduled Tasks. Create a new scheduled task and point it to the batch file you have just created. Schedule it to run 'At System Startup'. Make sure you tick the 'Run only if Logged On' checkbox otherwise you might some an error to do with passwords.

Everything works fine for me now.
Hey all,

So I've been having this problem too. I tried all solutions above, but none have helped. My OS is Windows XP (Media Center).

A couple notes:

I tried fangnyang's solution, and got the same results that BL describes (alll but two of the commands worked, still no dice). I have tried turning off my Windows Security Center firewall, but that didn't work either. My Virus scan is AVG (free edition), and doesn't seem to be an active scanner.

I tried Steelgrave's solution, but the "Netsh int ip reset" command didn't appear to work. The text that came up described some syntax error. When I called ATT support for help this afternoon (I have ATT Uverse for my internet/tv service), they had me run a similar set of commands. the dns flush worked, and the winsock reset worked, but the problem was not fixed upon restart. ATT had me run another command too, "[something] I i r r" was the command.

I tried Crag's solution then. The Wireless Zero Configuration did not have an option to restart, because it was not even started in the first place. So I started it; then I restarted the DHCP Client. But this did not fix it either.

So, any additional ideas would be welcomed (namely, by me). Another thing to note is that I reinstalled windows in an attempt to fix the problem. So, even after a "clean" install, this occurred. (I tried all your solutions after reinstalling windows).

I think I've got it now. This must be a problem with the Windows Security Center firewall in XP (and, I'd assume, Vista). I disabled my windows firewall and installed a 3rd party firewall (Zone Alarm). All appears to be working now.

(I was only able to log into yahoo after my Windows firewall was disabled for an hour or so, don't really know why that is.)
Thank you
Try clearing your cookies, browsing history and your temporary internet files. I tried all of the suggestions on here and nothing worked. This is what finally worked for me. Computer runs fine now.
hihohiho 2 Posts Sunday February 7, 2010Registration date February 7, 2010 Last seen - Feb 7, 2010 at 07:58 PM
Thank you
Opening page could not be found for any browser. I tried Safari, Firefox, IE, and Chrome.
Tried almost all of these great Forum recommendations, and alas what worked for my ancient Compaq Celeran back-up computer (saved barely from e-cycling) was resetting the DNS... (Domain number series)...

Each of the other three computers on our home LAN shared the same DNS number that was a different number than the DNS stored in my old Compaq. I tested on windows troubleshooting and the DNS showed as a failed test, also.)

So right click on the blinking internet icon in the lower right hand corner ( by the time) and open network connections. Click on the LAN connection that you are using. There are the magic connection numbers that give your unique IP on details, and more numbers... Check em out and see if all is the same with your other computer internet connections.

On the same "Status" screen, click on properties, and voila you're almost there...
Scroll down to TCP/IP, check mark it, select it and check out properties...
Even though "obtain an address automatically" is recommended, I chose" use the following"...and corrected the numbers that come up for the addresses...

I corrected the DNS (by changing a 1 to 0), and braved the "Advanced", clicked on the DNS tab, and oh my gosh, there were arrows to change my default DNS order of at this home, my computer is set for this DNS, and at the other home/office, I reset the arrows to point to the first DNS....

Instantly, all the numbers lined up, and I tried Mozilla Firefox with baited breath, AND IMMEDIATE connection!

Hope this helps someone in a similar boat (or boot :) !
THANK YOU!!! While this didn't EXACTLY work for me, it did get me looking in the right direction. turns out the obtain address automatically WAS NOT checked for the redirect automatically on IPv 6 although it was for IPv4... clicked that bad boy on and.... TADA! done!
Thank you
A simple problem be that a firewall update changed your internet security settings and is killing your browsers. Try temporarily deactivating your firewalls and see if that fixes it. If it does than go into your firewall program and change the internet security settings in it.
td > Steelgrave - May 12, 2009 at 03:30 AM
Thanks for the info.
Steelgrave.. Lotsa appreciations... Fantastic, it worked perfect !!
Omg this worked....thanks Steelgrave!
You are the MAN (or WOMAN). Your post helped me greatly! Now I can go to sleep (it's 12:45 a.m.).
Thank you
Ok guys, I found a way to fix this

The bad part is, is that it only works if you have a ipod of any sort

when you first plugged in your ipod you downloaded something called safari and if you didnt go to your itunes and do it

but safari is a amazing very high speed browser I use it all the time, trust me.

so look in your programs by doing this

1. Start menu

2. programs >

3. Safari

Thank you I hope it help :D
Thank you
Hi there !

I just want to share my experience with my IE problems and how I solved it.
I bought a new Sony Vaio laptop with VISTA pre-installed. I connected to my wireless router, but as some of you here, IE did not work. Got "cannot display the page" every time.
I tried quite a lot of the tips and trics on this forum but nothing did work.
Finally I uninstalled completely the Mc Affee software that comes with the vista or sony, restarted my laptop, and IE suddenly worked well :D
Small tip : I use AVAST as antivirus. It is free for home use and I never had problems with any software of virus. You can find it on

Thank you
I had a similar issue and had disabled windows firewall as a matter of course, tried running the dll's in cmd prompt and lo and behold it worked....until I restarted ldnt work at allthe pc and then it wouldnt work at all no matter how many times I tried them again....mate of mine told me noticed I hadnt disabled Panda Antivirus 2009 and that norton was still lurking in the far so good used the norton removal tool and need to re-install Panda browsers working fine :-)
Very Good !!!

I had the same problem. I had remove the norton utilities just by using the windows vista uninstall process. The computer started having problems after this and finished not accessing any URL from any browser.
I tried everething on this page, but the real solution on my case was use the norton removal tool.

Thank you
Check in Control Panel and see if you can find Norton Internet Security. Uninstall.
why? I have nortons antivirus system works 2003 and having this problem. I have an xp and use firefox... I've done a complete system restore to factory settings and still have the problem but the first thing I always install is nortons and then firefox. After an hour my internet won't load any pages. I'm not good with computers but I really need some help. will the above work?
Please anybody provide robust solution
fredymendez - Feb 22, 2009 at 10:36 PM
Thank you
First of all I wanna thank all of those who posted solutions to resolve this issue. Base on my knowledge and experience I am gonna tell you how to resolve this problem.
0) Restore your pc to a previous date. go to Start>accessories>systemtools?>system restore.
if that dint work try the following
1) Download and install Malwarebytes and scan and remove infected files.(Google it and u will find it its free)
2) If the above did not work. then try the following.
*Disable any antivirus and firewalls that you might have install. if this doesn't fix the problem try this.
*Unistall your antivirus. specially if its norton, then you can get NOD32 antivirus which is a better.

3) For IE:
In the browser, go to "Tools', 'Internet Options', "Connection", "LAN Settings" and uncheck all the boxes.
For Firefox:
In the browser, go to "Tools", "Options", "Advanced", "Network", "Settings" and check the "Direct connection to the Internet" button (leave all other buttons unchecked).

4) If none of the aboved work for you try the following suggestions from previous ppl,
a) Open a command prompt as an administrator--start>programs>accessories>start command prompt>right click and choose use as administrator.
b)Type the following commands without the quotes:
"Ipconfig /flushdns" and press Enter.
"Netsh int ip reset" and press Enter
Vista will then want to be rebooted. Go ahead and reboot.
When it starts back up, again open command prompt as administrator.
Type the following commands without the quotes:
"Netsh winsock reset" Vista will then want to be rebooted. Go ahead and reboot.

4) if all that dint work try the following:
1. in the cml run "regsvr32 actxprxy.dll" and "regsvr32 shdocvw.dll"
2. reboot windows

if the above couldn't fix the issues, run the following extra commds:
egsvr32 mshtml.dll
regsvr32 urlmon.dll
regsvr32 msjava.dll
regsvr32 shdocvw.dll
regsvr32 browseui.dll
regsvr32 actxprxy.dll
regsvr32 oleaut32.dll
regsvr32 shell32.dll
and restart the system once again

If all that dint work. I will suggest to get a copy of vista or windows xp and reformat your pc. by reformatting your pc u will lose all ur documents and files(pics,mp3s..etc) but it will solve the problem 100% .

If you need extra information you can contact me at or and I will gladly try to help you. I know its frustrating not to have something I WANT to help you.
I had tried all of the suggestions that you mentioned in your reply, none of which worked.. For me is really was as easy as clearing out my cookies (when I did it, I cleaned out my browsing history and my temporary internet files). Sometimes the simplest solution is the best one.
Your amazing your suggestions fix mine.
Thank you
I just had this same issue and fixed it by following these steps. Hopefully this will help you guys out too. I use Windows XP.

1st - Go to your control panel

2nd - Select the internet options thumbnail

3d - Under the 'connections' tab, click on the 'LAN settings button'.

4th - Make sure to UN-CHECK the little tick box next to the text that says "Use a proxy server for your LAN (These settings will not apply to dial-up or VPN connections"

5th - click 'ok'

this fixed my issue with internet explorer and google chrome instantly. I hope this helps some of you.
Thank you
I have the same problems as above, trying to get another laptop to browse the Internet through my wireless, the wireless connection strength is strong and the Wireless Network Connection is connected however Internet Explorer says they cannot display the web page, and I have tried multiple pages, all with the same result. I ran Spybot and discovered a nubmer of problems which were connected and after rebooting still nothing, also, I ran all the commands successfully except 2. The first was for "regsvr32 mshtml.dll" which I received the following message "regsvr32 mshtml.dll was loaded but the DllregistrerServer entry point was not found. This file can not be registered." The second was for "regsvr32 msjava.dll" which I received the following message "LoadLibrary("msjava.dll") failed - The specified module could not be found". I'm not computer savvy enough to know exactly what these mean, but this is really frustrating not being able to browse. Any help will be greatly appreciated. Thanks.
Thank you
Pls clear the history of your browser page,
Thank you
Hi guys, I encountered this problem also, but not all the time. I mean, connected but seems no internet at all. Sometimes, or most of the time I have connection though, but there were times I don't have internet but connected. My cousin told me about the spyware and she said maybe one of us who connects to that router has it. (yeahi think, 6 laptops uses the router) That's why I tried it with different router and it works fine.. I've tried scanning my laptop with ad-aware and avg and no viruses found. What does this issue mean?

Thank you

Hi, I had the same problem as you did on my W Vista computer: I was able to run MSG and Online games, but I wasn't able to use IE or Mozilla Firefox. This happened as soon as I downloaded the new version of my anti virus (AVG Free 8.5). Now I realized that the firewall was allowing both programs to have full access to the internet, so I started snooping around the AVG Tools and was able to figure out what was wrong. The AVG program has something called Link Scanner in "Tools"-"Advanced Settings". Now I haven't figured out what they are for, but as soon as I deactivated them, everything started to work perfectly again. Hope this helps. If not, try looking into your own firewall related programs or browser addons and think about what you did or downloaded the days right before the change. Good luck!
Lovelylaura12 3 Posts Saturday May 22, 2010Registration date May 23, 2010 Last seen - May 23, 2010 at 11:34 AM
You helped me so much! I can't believe it was this simple!
Thank you
i had the problem-internet explorer cannot display webpage. so I went and clicked the start button-in all programs I went emachine,clicked on emachine-open emachine recovery mangement. you will loose files but youre pc will be restore to manufacturer setup. just fellow their steps. I now have a pc that works,now I can surf the internet, good luck jose
notebookpc 24 Posts Monday August 25, 2008Registration date June 6, 2009 Last seen - Sep 6, 2008 at 06:15 AM
Thank you

well I think that you have been contaminated with some spywares which are blocking access for the internet.

what I would advice you is to download a software called superantispyware from and indtall it on your computer and have a complete full scan
I am having exactly the same problem as you guys. I have a Toshiba Equium laptop running Windows Vista Home Premium. I have both IE and Firefox 3.3. I normally connect to my router by wireless but sometimes I use a cable. A couple of days ago the problem started, it could not display any web pages. When I checked the status of the connection both wired and wireless all seems to be fine. In the network properties is stated how many packets recieved and how many sent. The wireless signal was stating excellent. I just can't view anything on the Internet. I have tried safe mode with networking as suggested by many of you guys out there and even tried the Microsoft troubleshooting, but nothing has worked for me so far. I did not have service pack 1 but I have since installed it but still the problem persist. I have tried a wide number of scans and some found quite a number of spyware and adware but even removing them does not make any difference. I would have restored (complete reinstall) my OS but now that they don't give a recovery CD anymore I am stuck. This is what is wrong about not getting a recovery CD when you buy a laptop or a computer form the suppliers. Any way can anyone help me please please. I desperately need my internet to carry on with my work. Please tell me what to do if you have had this experience. Tell me how to resolve this problem. Many Many thanks in advance.
irishman > Phil - Nov 12, 2008 at 02:07 AM
Try running LSPfix, download on another computer and transfer via flashdrive.
Hi Phil,
did you solved your problem with toshiba ?
I have the same HW and I can not open some web pages.

harryhill > Phil - Oct 5, 2009 at 02:40 PM
I used Norton Removal it displayed as normal.
Thank you
simply try to delete Cache under Tools and "Clear Private Data".
When he means cml, he means 'CMD'. It was a typo.

Start > Run > CMD
Thank you
Ive been haveing the same problem... fanhyang You are brilliant I think the problem has to do with cookies I only get this somtimes and if I go back 3 or 4 times it starts working.
1 2 Next