Windows Installer Service could not be access [Solved/Closed]

- - Latest reply:  nicki - Jan 14, 2013 at 05:30 AM
Hi, all!

I'm running Vista Home Premium on my PC. I tried to install a game (Bioshock) and at the very beginning of the setup, my computer blue-screened...

When I restarted my computer, a number of programs that I have set to run at startup crashed (including Skype, MSN Messenger, iTunes, Bitcomet, and even Windows Media Player)!

I tried to install the game again, and the same blue screen appeared. After another restart, all programs crashed again...

Also when I'm trying to start them manually, I got the following message: "Windows Installer Service could not be accessed".

I found an article on Microsoft support: http://support.microsoft.com/kb/315346.

Went through method 1. This did not solve the problem. However, when I tried to install Bioshock, I only got an error message (the setup never got started like before, but on the plus side I did not get another blue-screen).

Next I tried method 2, but when I completed point 3, cmd only said "file not found - dllcache".

Following advice given on an other forum I went to Add/remove programs to see if windows installer was actually there. And, guess what... It was not. So I downloaded Windows Installer, but when I tried to install it, I got the following error: "Not enough storage is available to process this command." I have about 200 GB of free space on my hard disk and 2 GB of RAM, so that seemed pretty strange to me.

Lastly, I downloaded windows installer cleanup, but when trying to install it, I got the same old error message "Windows installer could not be accessed."

I would really appreciate any help as this problem is driving me crazy.

Thanks a lot,
See more 

20/55 replies

1
Thank you
THANKS JASON!!
1
Thank you
Okay, so everyone who think this is a virus or something that comes after a long time is wrong. I formatted my harddrive yesterday, installed itunes, firefox and photoshop. When I tried to install msn, it didnt work. Now, nothing works. Ive tried everything u guys have posted here but still nothing works. Just got back after my 5th reboot in 3h so Id be happy to find something new.. Running XP and installed all updates recently
1
Thank you
hello guys before you do anything try this link.
this will give you four different methode to tackle the problem.
I spent hours to find it.
dont miss it.

http://helpdeskgeek.com/...
0
Thank you
having problems installing windows live messenger. it keeps telling me error. what can I do to solve this problem
0
Thank you
try some of the resolutions it has the first one worked for me


http://support.microsoft.com/?id=319624
0
Thank you
I tried all those methods, but the one that worked was to install the 4.5 version of windows installer for whatever system you have. Perfect. After you install it should automatcally reboot and be fine.
0
Thank you
This is what I did
1. right click at my computer at desktop click Manage
2. go to Computer Management / Services an Applications / Services
3. at the right frame, Double clicks at Window installer
4. at General drop down Startup type : Manual
5. at Log On choose Local System account and tick the box Allow service to interact with desktop
6. Click Apply
7. go back to General again click start
8. done
0
Thank you
1 Log on to your computer as an administrator.
2 Click Start, and then click Run.
3 In the Open box, type cmd, and then click OK.
4 At the command prompt, typemsiexec.exe /unregister, and then press ENTER.
5 Type msiexec /regserver, and then press ENTER.
6 Verify that the SYSTEM account has full control access permissions to the HKEY_CLASSES_ROOT hive in the Windows registry. In some cases, you may also have to add Administrator accounts. To do so:Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

go to http://support.microsoft.com/kb/315353 for ifo!!!! ok!!! you need Windows installer to do it if you

do not have it download it http://www.softpedia.com/... ok!!!!!!!
0
Thank you
Thanks so much,Jason ! .. I tried your method & it works perfectly ...
0
Thank you
This is what worked for me I have XP
1. Open Run, and type in services.msc then press Enter. Alternatively, go to Control Panel -> Administrator Tools -> Services.
2. Locate Windows Installer in the all install services listing.
3. Verify that the Status is Started. If the Status column is blank, right click on Windows Installer and select Start.
4. If you get error trying to force start the Windows Installer service, try to change the Startup Type to Automatic (default is Manual), and then restart the computer.

The above steps can also be performed via MSConfig to set Windows Installer service to auto start on boot up.
0
Thank you
jaosn's trick worked for me thanks jason :)
0
Thank you
GARY B IS THE MAN!!!!!

I've been going NUTS for the past week trying to sort this out, thank you sooo much!!!
0
Thank you
I have every little thing, but nothing worked, One thing I dint try is the DCOM Permissions, if any one has tried that reply this
Hi guys, I have had this problem for awhile never been able to fix it. Many great solutions here but none of them worked for my OS. Today is a HAPPY DAY!!!!!! I finally found one that works for Vista 64 bit....here is the link, method 1 worked for me like a charm... free at last....whew!

http://helpdeskgeek.com/...
0
Thank you
After spending a week on this issue, the only thing that worked for me was downloading this file from another
site.It was a Registry entry and I could not believe that something so simple did the trick for me.

The file was named: MSICUU.
0
Thank you
I had the same problem, so I tried turning off Kaspersky. It worked fine after that.
0
Thank you
After I ran ComboFix (to see if I had and then cleanup any malware or other nasty stuff) on my Windows 2000 Pro computer:

1. Add/Remove Programs (accessed thru Control Panel) stopped working (blank window no programs were listed to add or remove).

To fix I d/l'd, installed and ran Dial-A-Fix program.

2. Windows Automatic Updates stopped working.

To fix I followed instructions by "plodr" in this linked thread:

http://forums.majorgeeks.com/showthread.php?t=155978

These solutions found after much searching. Hope this will save others some time and trouble.
0
Thank you
Good Grief, I forgot to add in previous post that this was related to having trouble trying to install programs also after running ComboFix using Windows Installer (*.msi) which is the subject of this thread. With Windows all this stuff seems to be intertwined...
0
Thank you
my service pack 2 windows installer does not want to install any programs please help


many thanks
0
Thank you
why is my msi when I turn it on it gos to window xp then gos to the started again please can it be fix ??? please email my m.mccellis@btinternet.com
0
Thank you
cannot access my e-mail and exployer keeps crashing. get message windows installer cannot be found.