Windows Installer Service could not be access

Solved/Closed
JudySis - Feb 13, 2008 at 05:22 AM
 nicki - Jan 14, 2013 at 05:30 AM
Hi, all!

I'm running Vista Home Premium on my PC. I tried to install a game (Bioshock) and at the very beginning of the setup, my computer blue-screened...

When I restarted my computer, a number of programs that I have set to run at startup crashed (including Skype, MSN Messenger, iTunes, Bitcomet, and even Windows Media Player)!

I tried to install the game again, and the same blue screen appeared. After another restart, all programs crashed again...

Also when I'm trying to start them manually, I got the following message: "Windows Installer Service could not be accessed".

I found an article on Microsoft support: http://support.microsoft.com/kb/315346.

Went through method 1. This did not solve the problem. However, when I tried to install Bioshock, I only got an error message (the setup never got started like before, but on the plus side I did not get another blue-screen).

Next I tried method 2, but when I completed point 3, cmd only said "file not found - dllcache".

Following advice given on an other forum I went to Add/remove programs to see if windows installer was actually there. And, guess what... It was not. So I downloaded Windows Installer, but when I tried to install it, I got the following error: "Not enough storage is available to process this command." I have about 200 GB of free space on my hard disk and 2 GB of RAM, so that seemed pretty strange to me.

Lastly, I downloaded windows installer cleanup, but when trying to install it, I got the same old error message "Windows installer could not be accessed."

I would really appreciate any help as this problem is driving me crazy.

Thanks a lot,
Related:

55 replies

Click Start/Run and type:

net start MSIServer

press ENTER and try installing again.
123
hey jason,
I tried doiong that and it still says windows installer could not be accessed...any other suggestions
0
Anand.Periyasamy > kathypray
Apr 2, 2009 at 04:56 AM
hi

I got the sam error in win 2000.
Solution :

1) Boot OS in Safe Mode.
2) Then in Run Command type msiexec\regserver
3) restart in Normal Mode

Now can install.
0
yicker124 > Anand.Periyasamy
Apr 2, 2009 at 09:33 AM
Many thanks for that tip: it worked for me! Outstanding, Anand!

yicker124
0
Tom > yicker124
Apr 21, 2009 at 06:18 AM
Hi...I'm having the same problem you had back in July 2008 and ran across these posts. I am trying to install iTunes version 8 and it says that my installer is missing a program needed to run. I was reading the posts that you had been making and the advice that you took but none of it worked for me. I'm running Windows XP with SP 3. Can you tell me how you solved your problem? I tried everything and now I cannot install new software on my computer. It's like having a disposable computer. Any advice you can give me would be appreciated.
Thank you...
Tom
tdemicke@rio.odn.ne.jp
0
jamieleesummers > Tom
Mar 8, 2010 at 03:53 AM
I'm stuck!!! I cannot seem to resolve the issue I'm having with windows installer!! I'm using windows XP service pack 3 and I keep getting the error 3: System cannot find path specified. Could not start windows installer service on local computer. If anyone has any suggestions or advice, please please contact me!!! You can reach me via email and under subject put: Windows Resolution! That way I don't accidentally delete it thinking it's spam. PLEASE HELP???
0
Hello. Had similar issue with a client running Windows XP SP2 and pretty much worked through suggestions here to no avail.
What eventually got it working.
Under Control Panel -> Administrative Tools -> Services
Right click on the Remote Procedure Call (RPC) Service
Select Log In Tab
Select Log As "Local System account" and tick "Allow service to interact with desktop"
You'll get a message that settings wont take effect until you restart the service. To do this you'll need to reboot your PC.
After reboot installer service seems to behave itself again.
Took me 2 hours to find this so hopefully my pain will save someone some time.
45
Thank you very much my dear friend, you saved my life.

I tried all the things like re register, re install installer, registery edit etc.

this is the only one worked for me

thank you thank you.
0
Yeah, I had a similar problem with Installer on XP SP3, and the only thing that fixed it was to tick the interaction with desktop. This was not one of the top 10 solutions provided by microsoft. I had to figure this one out on my own.

Greg
0
kholil > greg
Feb 1, 2009 at 07:43 AM
Hi Greg,

I can't get to administrative tools to follow your suggestion.

I tried everything else but nothing has worked.

Could you help please?

Cheers

Kholil Uddin
0
Quinny > kholil
Oct 7, 2009 at 12:56 PM
right click on my computer, click on Manage,Click on services and apps in the right hand side window, then Click on services, this will open it for you. hope you understand. =)
0
I have tried every method on this page, including yours. In addition, I also tried Microsoft's "solutions." None of these changed the behavior of my system in any way (including re-installing XP). I still get the error message whenever I try to install anything using MS installer service. I am using XP SP2. Like others, this problem was first intermittent, then persistent. Others have suggested it is a virus, but NOD32 finds nothing suspicious. I have been working on this for a month and am almost ready to throw the whole damned system away or scrubbing the disks. Unfortunately, that is not an option. I am a professional developer with over 3 million files on my system...including hundreds of very large programs that would take weeks (months) to re-install even if it worked, and I have no way of knowing if even THAT would work!
0
Try this:


right click command prompt and chose "run as administrator" . Type "regsvr32 c:\windows\system32\msi" press end and try to install again.
43
thank you!
0
Thanks a lot! :)
0
You are the best. thanks.
0
i had this problem for a long time , and now it's fixed !!! thank you so much
0
This was the fix for me running xp pro sp3, after I looked everywhere. I just wanted to say Thank you! You saved me a couple of days for sure. Doc.
0
I had the same problem on my Windows XP Media Center - tried many of the suggestions above and nothing worked. Finally found a suggestion at Microsoft's website to do this and it worked!

Method 1: Unregister and re-register the Windows Installer
Click Start, click Run, type MSIEXEC /UNREGISTER, and then click OK. Even if you do this correctly, it may look like nothing occurs.
Click Start, click Run, type MSIEXEC /REGSERVER, and then click OK. Even if you do this correctly, it may look like nothing occurs, or you may briefly see an hourglass. After you run this command, the operation is complete.
Try your Windows Installer-based application again.


So give that a try - it worked for me.
41
Thanks an this worked for me.
0
Awesome! It worked!
0
worked like a charm, thanks
0
it's worked, thanks for the help
0

Didn't find the answer you are looking for?

Ask a question
Hi guys I have a lil problem :
When you say open "Services" and click on "Windows Installer" tab on the right side , problem is that I dont have it , the "Windows Installer"..What can I do?
13
This one worked for me when installing Itunes 8 on Vista 64 bit, with the 64 bit installation.

https://www.windowsbbs.com/threads/vista-home-premium-x64-and-installing-itunes-solution.82460/

I had tried every possible other solution sugested here. I hope this helps.
12
thanks for the link molab, cant believe it worked, going through procedure after procedure. thanks again

(btw im running vista64)
0
Thank you malob for taking the time to post that link for us. That is the solution that finally worked for me when no other one would. It also explains why I only got the error message on SOME installations (the 64-bit ones apparently). Now my installations are all working without a hitch. Thanks again!
0
This solution worked for me to install tune 9.1 on windows 7 ultimate 64 bit. Thank you!
0
I have no same exact freaking problem, Vista was a waste of money and time.
8
Working on husband PC since this AM. After tying all that I read, calling HP and Microsoft, no support, I am so glad I found this forum. What finally wokred for me. PC is a HP laptop, OS XP SP3.

1. Click Start-->Run-->type services.msc press Enter
in the Service window select Server.
if its stopped please start it and if its running please restart the service. I stopped it and strted it again.

2. Then went to Windows Installer previously changed to automatic from manual and also checked under logon tab "Allow service to interact with desktop". Previously tried to start services, would not start.

After I stopped and started the local server, I was able to start the window installer services and then install all my software.

Hope this helps someone.
7
On someone's advice, I disabled the firewall and rebooted twice. Windows installer finally worked. Eureka.
6
Shamzel - thanks for that! I was looking every where for an MS KB article. Mines working now.
0
millertime199 > Diezel619
May 13, 2009 at 04:11 PM
If the command msiexec\regserver does not work you can try msiexec /regserver and see if that works. If you get a mesage saying there is "...already an installation in progress" open task manager and end the "msiexec" process then try again.
0
worked
0
I have tried almost all the methods suggested and all in vain. VISTA is a total freaking OE. Almost everything hang.
Can't :-
Add and Remove Applications
Internet Explorer - No display.
Window Mail - No images or pictures display.

VISTA is a waste of resources, money, efforts and time.

Gone case.
4
Same thing happens with Windows XP, and unfortunately all the browsers just happened to want to upgrade right after my windows installer decided to stop working, so now I'm stuck with only two old version browsers that at least work at some level and a few sites telling me "you might want to upgrade- there's hundreds of ways to do so.. we no longer support your browser". I've had to put up with this for over a month now. It's probably best to work extra hours if possible and just accept the fact you might need to get a whole new computer. I can still use certain programs as long as they are already installed, but it's a real hassle not being able to install what I want / need, and having to settle for "good enough" when things were once working and installing perfectly. I wonder if ever since my installer stopped working, has any security updates really been installing, or is it just wasting my time telling me "installing updates... wait" when in reality nothing is being installed at all?
0
JenJen, you are da bomb! Thanks so much for your answer (for which I had to say "duh" and slap myself on the forehead...)!!!
3
the same thing is happenin to me.. im using xp. I was trying to uninstall eset security but failed. so I removed the folder but the file is still in my programs and features. can't remove it. tried all registry 'mechanics'. cant even use windows clean up utility
3
i think u r missing some dll files and need to do a system repair or reformat with ur system disk
3
delete all temp files under C:\Documents and Settings\ahr\Local Settings\Temporary internet files and C:\Documents and Settings\ahr\Local Settings\Temporary internet files, where "ahr" is your user account in windows
this may solve your problem
biggboss
3
GaryB, your solution worked for me. Had this problem for months!!!
2
WOW JASON U ROK!!! THX
2
PhillyOverclocker
Feb 20, 2010 at 11:21 AM
I was able to get past the error by using an XP Home disk with SP3 already slipstreamed into it. This was after doing registry fixes, running CHKDSK /r, etc.
2
TYY all lol. helped me =].thanks for veryone to help
1
THANKS JASON!!
1