Unresponsive External WD 80gb Hard Drive

Closed
BBQbob - Dec 15, 2008 at 03:25 PM
 hatch - Jan 22, 2009 at 12:34 PM
Hello,
I currently have a 1 year old 80gb Western Digital External Hard Drive. However, when I tried to plug it into my computer this morning, the light lit up, but instead of the hearing the fan whirr, I heard 18 beeps, with space between every 3, and then the drive just became quiet, and my computer did not recognize it at all. I tried to plug it in again, but the same scenario occurs every time I try. Does anyone have any ideas?

1 reply

mine is doing the exact same thing but my computer now recognizes it as "wdc rom model-scorpio--usb drive" it says its installed and ready for use but when i search for it it shows no match...im lost i have no idea i do know i have years of files backed up on it that i need desperately!! anyone please help the manufacturer wants 50 bucks just to use their tech support and they cant gurantee they can fix it i didnt even pay that much for it brand new!
1