Problem with dates in Excel 2004 MAC

Solved/Closed
Szimitar - Dec 18, 2008 at 11:30 AM
 Daisy - Jul 19, 2010 at 03:26 PM
Hello,

I'm working in MAC OSX
MS Office 2004 11.5.3 (081114)

I have two workbooks opened at the same time.
I copied 54K+ rows of data from one sheet from WBK-A into sheet in WBK-B.

Column C has date values (unformatted so they look like integers)

Both sheets contain a cell with value 39782.

When I format that cell in WBK-A as Date:MM/DD/YY it displays 11/30/08
When I format that cell in WBK-B as Date:MM/DD/YY it displays 12/01/12

This happens on many cells not just this one. It does not happen in the first few rows.

My head is about to explode but I know this is either a bug or the result of some
odd (hidden to me) inconsistency in settings between these workbooks or sheets.

Any help much appreciated.
thanks,
Sz

5 replies

Szimitar
Posts
1
Registration date
Wednesday December 17, 2008
Status
Member
Last seen
December 18, 2008
6
Dec 18, 2008 at 12:10 PM
Found the answer.

There is a default setting in excel preferences to use 1904 date formatting.
Just uncheck that and dates are the same
.
6
aquarelle
Posts
7118
Registration date
Saturday April 7, 2007
Status
Moderator
Last seen
July 29, 2022
491
Dec 18, 2008 at 03:37 PM
Hi,
Thank you for coming back to give us the solution you have found. You can be sure that this will be helpful.
Best regards
0
Awesome! I was just on the verge of having exploded head syndrome, when I found your solution doing a Yahoo search.

Thanks!
0
For people that have the mac file only and don't have either a Mac or Excel for Mac.
I don't have one on hand so I had to save the file as CSV and then reopen it.
Make sure you chose the right date format - if you have hours/minutes/seconds you might lose them.
0

Didn't find the answer you are looking for?

Ask a question
Hi,

Was just reading this post and thought I would add my 2c's. If you're struggling with this in excel chances are you will struggle with t all over the place.

In OS X Go to system preferences>date & time. Hit the format tab. Then click on international settings. Check out whether its US. Then if there is change it to your reigon. Fixed....across the board :)
-1