Shortcut virus on flash drive

Solved/Closed
arun - Updated on Nov 27, 2018 at 08:30 AM
 Baws - Jan 7, 2019 at 01:22 PM
Hello,

all my folders in my flash drives are converted into shortcut icons.how can I clear the virus .is there any antivirus software to clear such virus. if u have any answers regarding this please.

System Configuration: Windows 7 / Internet Explorer 8.0

4 replies

jack4rall
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Updated on Nov 26, 2018 at 03:01 PM
Hello,

If you did not format your flash drive, then check whether the files are not in

hidden mode. Follow the following steps.

Step 1:

Click on the below link and download the file "AutorunExterminator"

https://ccm.net/downloads/security-and-maintenance/5911-autorun-exterminator/

Extract it --> Double-click on "AutorunExterminator" --> Plug your flash drive now.

This will remove the autorun.inf files from your flash drive and also from drives.

Step 2:

Click on "Start" -->Run --> type cmd and click on OK.

Here I assume your flash drive letter as G:

Enter this command.

attrib -h -r -s /s /d g:\*.* 


You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Don't forget to replace the letter g with your flash drive letter.

Now press "Enter".

Now check for your files in Flash Drive.

Step 3:

After that, download the Malwarebytes' Anti-Malware from the below link

https://ccm.net/downloads/security-and-maintenance/4621-malwarebytes-anti-malware/

Update it --> Perform "Full Scan"

Note : Default selected option is "Quick Scan".

Good Luck.
454
Thanks a lot buddy. it works and is very quick too.
0
https://ccm.net/downloads/security-and-maintenance/4621-malwarebytes-anti-malware/ not working.
after removing flash and re inserting virus is back. malwarebytes reports no infection....
0
jack4rall
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Jan 8, 2011 at 12:30 PM
Hello,
Try this 1
1)Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist" -->
Open a "Notepad" --> Paste it --> Save the file as fix.reg
Note: Don't forget the extension "reg"
Now double-click on fix.reg --> Click on OK.
------------------------------------------------------------------------------------------------------------------------------
REGEDIT4
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
@="@SYS:DoesNotExist"
--------------------------------------------------------------------------------------------------------------------------------
Note : After following the above instructions, whenever you place any autoplay CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive --> You have to double-click on the setup file.
2) Disable the "Autoplay" feature also.
Click on Start --> Run --> type gpedit.msc and click on OK.
Double-click on "Computer Configuration" --> Administrative Templates --->
System. Double-click on "Turn autoplay off" option and select the option
"Enabled" --> Click on OK. Close that window. Now logoff and logon into your account.
Now backup all the data from your flash drive and format it
Good Luck
0
It definitely works!!!! Thanks
0
very good .
it worked perfectly and worked perfectly.thank you very much
0