Can't open up my external hard drive

Closed
JupeRock87 - Jan 5, 2011 at 10:14 AM
 guy - Jan 6, 2011 at 01:02 AM
Hi, I have a 1TB Hitachi Lifestudio drive that is relatively new. It was working just fine until yesterday when I went to bring it to my friends house. When I plugged it in her computer it wasnt letting us open the folder without formatting it. Then I brought it back home and it is doing the same thing.

One really odd thing is that now when it shows up in my computer it shows up as "Local disk (F:) instead of Lifestudio (F:) as it always has in the past. When I click on the drive it sort of freezes up and after a while asks if I want to format at the expense of losing all my files. When I right click on the disk it also freezes up. If I go into device manager however I can see it in there as the Hitachi USB device and it says that "The device is working properly". If I go to the disk management thing it again says that it is Healthy and active. I am sooo completely confused. What happened to my external? Can I get my music off of it?
thanks a lot for any help!

2 replies

vista.ultimate.64
Posts
211
Registration date
Sunday October 3, 2010
Status
Member
Last seen
October 18, 2013
40
Jan 5, 2011 at 11:24 AM
hello

to be honest, I don't know whats wrong with it, but you can try a software called MiniTool Power Data Recovery. The link for it is

https://download.cnet.com/MiniTool-Power-Data-Recovery-Free-Edition/3000-2248_4-10561431.html?part=dl-6285158&subj=dl&tag=button

Select 'Lost Partition Recovery'. Hope i could help, good luck.
2
that happen to me to. i disconnected the power for a few mins then tried it again on a different pc and it worked. i have been having many problems with this drive too. after much time spend trying differnet things i have come to the conlusion that when removing the drive, if you dissconnect the power first you will encounter problems, always disconnect the usb cable frst. also some times when reconnecting the drive windows doesnt detect it. a simple restart fixes that. my adivce is, if you ever get it working get all your data off, then format.

once i formated i never had this issue again. you must do a full format
0