Recover hidden data from external hard disk

Solved/Closed
Aman - May 5, 2011 at 12:30 AM
 nanaa - Jun 21, 2017 at 12:59 PM
Hello,



Hello,
I have so many movies, files, folders & musics in my external hard disk . Due to some virus or something I don't know when I opened the external hard disk I can't see some folders inside it, but if I wrote at the top at the search bar the folder name or the movie name which are in inside the hard disk I can find the folder . So please if you can tell me what is the problem .

2 replies

bionik Posts 4233 Registration date Thursday August 19, 2010 Status Moderator Last seen August 3, 2016
May 5, 2011 at 03:46 AM
Hello,

Try this 1.

May be the files are in hidden mode.

Click on "Start" -->Run-->type cmd and click on OK.

Here I assume your external hard drive as G:

Enter this command.

attrib -h -r -s /s /d g:\*.*

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Don't forget to replace the letter g with your external hard drive letter.

Now press "Enter".

Now check for your files in external hard drive.

Good Luck.
50
thanx man ...i was worried abt my ...collection of colllege pics, family pics, and many more ...it was a big setback...when I was unable to retrieve my data...but...................by ur simple command of DOS I got all of it ..........thanx once again.....tc.....
0
bionik Posts 4233 Registration date Thursday August 19, 2010 Status Moderator Last seen August 3, 2016
May 17, 2011 at 02:24 AM
All the pleasure was mine Hari!
0
THANK YOU!!! This was exactly what I needed... dang virus hid all the files on the external drive but I knew they were there because of the space allocation.
0
I have tried your dos command but my it retained unreadable FILE0000.CHK more than 10 thousand am worried I might have corrupted my files further any solution for this
0
thanks yar
0
Blocked Profile
Oct 31, 2012 at 01:30 AM
Perhaps, your files have been changed into hidden mode. You can do the following steps to show them again:

Start=> Run=>Enter "control folders" in the blank and click "Ok"=>Choose "View" on the appearing "Folder Options" interface=> Select "show hidden files and folders".
7