Shift key doesn't work

[Closed]
Report
-
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
-
Hello,

my computer was working fine yesterday, but today, i've found that my shift keys are weird. in addition to capitalizing the next letter, it also types and "x" for the left shift key and a "w" for the right shift key. so that when I try to type it appears like this:

wMy computer's wShift key is w"weirdw"

please help! it's hard to type like this.

1 reply

Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
44
Hi alec,

This problem might happen if there are multiple language keyboards selected in Text Services and Input Languages. To remove additional languages from Text Services and Input Languages:

1. Click Start and type "Region and Language" in the search box.
2. Select "Region and Language" from the search results.
3. Click Keyboard and Languages tab
4. Click Change keyboards...
5. Click general tab
6. From Installed services remove any other unwanted language.
7. Click Apply.
8. Click OK.
9. Finally, click OK on the Region and Language window.

If you are using Windows 8, try the below mentioned steps and remove other languages from the keyboard layout:

1. Swipe in from the right edge of the screen, and then tap Search.
2. If you're using a mouse, point to the upper-right corner of the screen, move the mouse pointer down, and then click Search.
3. Enter language, choose Settings, and then tap or click Add a language.
4. Unselect all the languages except US English.
5. Tap or click Options next to the language name, and then under Input method, tap or click Add an input method.
6. Browse the input method list or use the search box to find the keyboard layout you want to use.
7. Double-tap or double-click the keyboard layout, and then tap or click Save.

Do reply with results.