All the folders turned to shortcuts

Solved/Closed
Report
Posts
2
Registration date
Wednesday May 8, 2013
Status
Member
Last seen
May 9, 2013
-
Posts
2
Registration date
Wednesday May 8, 2013
Status
Member
Last seen
May 9, 2013
-
Hello',
I have a problem in my external hard disk. I connected this one in my friend pc all the folder showing only shortcut only. Then I removed from that pc and I connected to my pc its showing virus. I scan the Disk and removed the virus .again I connected then folder not there, when I search some thing its there, property also showing 300gb.How I solve this one. give me an advise.
thanks

2 replies

Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,

Try this 1

Follow all the steps given below

1) Disable the "Autoplay" feature. Click on the below link "Disable Autoplay",

and download the file --> Double-click on it and follow the instructions.

Disable Autoplay

2) Disable the "Autorun.inf". Click on the below link and follow the instructions.

First backup your registry. Click on Start --> Run --> Type regedt32 and press

Enter. "Registry Editor" will be opened.

( If you are using Windows 7, Start --> In search bar--> Type regedt32 and press

Enter.)

Now backup your registry by going to "File --> Export" --> Save the file with any

name in your desired location.

Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist"

REGEDIT4       
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]       
@="@SYS:DoesNotExist"  

Open a "Notepad" --> Paste it --> Save the file as fix.reg

Note: Don't forget the extension "reg"

Now double-click on the fix.reg file and then click on "Yes" to merge it,

[Note : After following the above instructions, whenever you place any autoplay

CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive

--> You have to double-click on the setup file.]

3) Click on the below link and download the file "AutorunExterminator"

https://ccm.net/download/download-11613-autorun-exterminator

Extract it --> Double-click on "AutorunExterminator" --> Plug your Pen drive

now. This will remove the autorun.inf files from drives and and also from your

Pen drive.

[Note : AutorunExterminator need Dot Net Framework. If its not installed in

your PC then click on the below hyperlink ".NET Framework" and download it

.NET Framework

4) Click on "Start" -->Run --> Type cmd and press Enter.

"Command Prompt" will be opened.

Here I assume your external drive letter as G:

Enter this command.

attrib -h -r -s /s /d g:\*.*

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Replace the letter g with your external drive letter.

Now check for your files in external drive.

5) After that, download the Malwarebytes' Anti-Malware from the below link

https://ccm.net/download/download-105-malwarebytes

Update it --> Perform "Full Scan"

Note : Default selected option is "Quick Scan".

Good Luck.
Posts
2
Registration date
Wednesday May 8, 2013
Status
Member
Last seen
May 9, 2013

Hello,
I did this one, it is ok now.
Thank you very much for your good advice.
Shibu

Best Regards,
Shibu Jacob