Messenger 2009 won't open email link [Solved/Closed]

Report
-
 andyc -
Hello, I have tried to find the answer in the forum but so far no luck.
Firstly Microsoft FORCES you to install the latest version of Messenger. I was using 8.5 with no trouble and had to upgrade to Messanger 2009. What a mistake that was!
All installed fine, and if can used just as before, however, the link to email inbox does not open the IE browser as it used to. Nothing happens at all. Even if I already have IE open, it still won't go to the Hotmail Inbox.
Similarly, when people are offline, you should be able to "send other" - "email", and this also then opens the Hotmail New Message in IE. This doesn't work either, and there are other weblinks which don't work.
This is a pest because I have to check Hotmail directly from the Hotmail page instead of just clicking on the Messenger link. A backward step? Or am I amissing something.
WORSE - I thought, oh well, I'll reinsntall 2009 and go back to 8.5. SORRYYYYYY --- "There is a newer version of Messenger available and you MUST instal it to continue" -- "Do you wish to install it now?" If you click NO, then you cannot do anything! BLACKMAIL - forces you to install 2009 which doesn't work!!!
What is the solution pleeeeeeeeeeeeese!?

22 replies

I had exactly the same problem, but I also noticed that links weren't opening in Outlook express or last.fm. I followed the following guide and this sorted the problem. Hope it helps you out too:

ake Links Work in Outlook Express, Outlook and Any Other Email Program

To make web pages open again when you click links in emails:

* Make sure neither Outlook Express nor Internet Explorer are open.
* Select Control Panel from the Start menu.
* Click Internet Options.
o If you do not see Internet Options right away, click Network and Internet Connections before.
* Go to the Programs tab.
* Make sure Internet Explorer should check to see whether it is the default browser is checked.
* Click OK.
* Close Internet Explorer.
* Re-open Internet Explorer.
* Click Yes when asked Internet Explorer asks "Internet Explorer is not currently your default browser. Would you like to make it your default browser?"
o If Internet Explorer does not ask:
o Close Internet Explorer
o Select My Computer from the Start menu.
o Choose Tools | Folder Options... from the menu.
o Go to the File Types tab.
o Highlight (NONE) URL:HyperText Transfer Protocol.
o Click Advanced.
o Highlight open.
o Click Remove.
o Click Yes.
o Click OK.
o Now click Close.
o Start Internet Explorer.
* If you use a browser other than Internet Explorer, start it and make sure it is the new default.

The above does not work? Try this:

* Now select Run... from the Start menu.
* Type "iexplore /rereg".
* Click OK.

Or, if that fails, continue with:

* Select Run... from the Start menu.
* Type "regsvr32 urlmon.dll".
* Click OK.
* Click OK again.
* Repeat the Start | Run... procedure with the following commands in this order, maybe checking after each for returning function:
o "regsvr32 shdocvw.dll"
o "regsvr32 mshtml.dll"
o "regsvr32 browseui.dll"
90
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Thanks Stevo! u r brilliant!!! I solved my problem! ^^
Thankyou. Worked a treat.
Thanks for the advice Steve my links in Outlook Express are working and l can now open my msn messenger inbox just by changing my default browser to Internet Explorer thankyou very much!!!
My msn messenger inbox couldn't be open for many months but its all good now.
Thx alot!!!
nothing above worked
Hi guys, I just helped a friend solve her problem. Initially, whenever she clicks on the email inbox icon on her new WLM 2009, it automatically opens in Firefox. I found out that you can actually open your hotmail in IE by doing this way:

Btw, she is using Windows XP Pro.
1. Go to Control Panel
2. Go to Add/Remove Programs
3. Click on the Set Program Access and Defaults tab
4. Choose the Microsoft Windows configuration

It does work on here. Hope it works for you.
> fonikz
This simplified method worked for me.
I fixed the problem by making IE my default browser (bastards!)
Open IE
Select "Tools" from the menu bar.
Select "Internet Options" from the drop down menu
Select "Programs" from the tab menu
Make IE your default browser.
Yeap Thx buddy that is realy good one
Yep yep! been looking for somthin that works here it is!
Thanks Phil You are the man Very simple I looked for a solution everywhere
cant find add 0r remove program--or -set programme tab
HI HELP IVE JUST GOT NEW LAP TOP AND WHEN I GO TO MY E MAIL PAGE THAT OPENS FINE BUT WONT LET ME OPENMY MAIL
thank u very very much mate u are a star ive trying to do this all day and nite and even intalled the old version of msn just cos of this lol thanks again
Thanks Stevo. The first bit sorted my problem out too
In Vista, we don't have a file types tab in folder options, you have to do it through Default Programs under Control Panel. But the problem there is, I can't remove a file type, only change what program opens it, and IE is already the default for the URL:HTTP. But my IE was not set as the default browser and somehow was not set to detect that it was not the default browser.

After making it the default browser through IE, it still didn't work :(
Metalpura

Thank you, i've looking how to do that, thank u you save alot time,
also big thanks to Steve
i can sign in msn but then wen I want to look at my messages that I have it wont let me. and I need to see one of the messages because its one of my pass words I need to have to get into somethink.i have 11 and every time I press it it loads then just says internet dignosed problem then I do and it just stays there can some one plz plz help its really anoying xx ty
o Select My Computer from the Start menu.
o Choose Tools | Folder Options... from the menu.
o Go to the File Types tab.
o Highlight (NONE) URL:HyperText Transfer Protocol.
o Click Advanced.
o Highlight open.
o Click Remove.
o Click Yes.
o Click OK.
o Now click Close.
o Start Internet Explorer.
* If you use a browser other than Internet Explorer, start it and make sure it is the new default.

When I try and tools / folder options I cant see that option anywhere? I click start, then computer, but cant find the tools tab?

Any suggestions?
Its at the top, File, Edit... Tools.

MY problem is that there is no "File Types" tab that I can see....
I done that and it opens firefox(my default browser) but I still have to type my password and login to my email account.
Is there anyway to have it open up automatically signed in like it used to do on the old msn messenger through IE.
I have done this. I have Firefox as my default browser, but now it opens my email with Internet explorer. also if I open firefox it will sign me out of messenger. now what?
Explanation :)

to open your inbox directly from the messenger, the messenger is sending a message to your browser ( sorry if I make some english mistakes) this message is agreed upon by the browser and messenger, for sure the message wants to target the internet exploere which is the only software can understand it .and according to it go to the suitable page, if firefox wishes to help in this function , mozilla needs microsoft's support I think, some people said opera browser do it, this makes the one wonder if microsoft supported opera browser or that the messaging between the messenger and internet explorer is simple to analyze and not encoded, if not encoded maybe we can see firefox works one say, the solution of making IE the defualt browser is the right solution, I want to add, if you deleted firefox , the IE will be the dafault browser automaticaly, but IE still doesnt serve you until you go and make it the default as what Stevo said, is it a bug in IE?
THANKYOU!! Worked like a dream..took all of a minute to fix a promblem buggung me for weeks. Thank you again.
Ok folks I think I figured it out. And you can thank Micro$hit for this one! I don't mean to write a book over it, but if you understand what its all about then this problem might apply to you. ( Many thanks for nothing to Microshit for all there so-called support). Here we go... I had downloaded and intalled IE8,as so many have been forced into this by Micro$hit, and as many of us found out...its another fine piece of crap! Now, Micro$hit tells everyone "your shit out of luck, you downloaded it and F%ck you!". Right? WRONG! Here's what they don't want to know! First you'll have to uninstall Sevice Pack 3, SP3 locks your IE that can't be removed. Once you've deleted SP3 you can now remove IE8. Now I did all this, and it does take time so be patient. After I did this and downloaded SP3 I was able to keep IE7! Buuuuuuuuuut!, when it came time to open email in my inbox, it wont work?! So the only way to open is with IE8 orrrrrrrrrrrr! Google Chrome! So obviously Micro$hit has set things up that your forced to use IE8, but not if you use Google Chrome. If you need help deleting SP3, go to https://www.tech-recipes.com/rx/2817/how_to_uninstall_ie8/ and use Graywolf_ANF details on how-to. If you find this works for you please leave a thank you to him as he seems to know what to do (not like Microshit will!). Remember, once you have deleted SP3, then you delete IE8,then you can update SP3,add Google chrome, and thats it! hope this works for anyone, leave a post and lets see how we do! JLS
This fix only makes IE work for me, but not FF... even if I set FF to be my default browser. I tried all of the suggestions in here but links are still broken for when I set FF to be my default browser (nothing happens when links are clicked within WLM9). I do not use IE as my default browser, so I can't set it to that.

Any idea why linking might be completely broken when FF is set to default? I read everywhere that WLM9 should open links in your default browser without any further configurations but after upgrading from WLM8.5 to version 9, the links have become broken. I used to use StuffPlug in WLM8.5 to force links to open in FF but since StuffPlug is not compatible with WLM9 anymore, I can't use that method anymore.
Hello, I just fixed a similar problem in windows7 Chrome was set as my default in the chrome tools>options. However when I launched WLM and clicked on the email link or any of the storys from the Today screen, nothing happend at all. It was working fine since install of win7 a few weeks ago. Here is how I fixed it. Click start then type default programs in the search bar. Then clik on defailt programs at the top of the tool bar in the start menu. Next click on the Chome.username not just the chrome item. Then click set as default. Then all of the WLM funtions work using chrome. I say this will fix any issues with IE8 as well because it was listed in the default programs list. Cheers, DAfreak
> C4Dfreak
Heres a solution that worked for me:

1) uninstall msn messenger
2) open a new email account using gmail, yahoo or others.
3) have your hotmail account forwarded to new email account.
4) uninstall IE and everything else msn related.

So basically give entire control of your computer to microsuck and you can open hotmail with msn messenger. I say BS.

I have a 64 bit machine. I just put in Windows 7 to replace the love Vista. I use have always used Outlook or Microsoft mail with a charter.net email address. With Win 7 , neither program is availabl. I was told to use Windows Live Mail.

I did so, and found that I can not open links I receive in my email with my preferred with my default browser, Firefox. I HAD to make my default browser Internet Explorer.

I am shocked that Microsoft would go so low. It is disgusting show of greed. When I was growing up, we heard about communist plots. As an adult, I see capitalist plots all around me.
Posts
1
Registration date
Friday February 12, 2010
Status
Member
Last seen
February 12, 2010

Hello folks !!!!

I had face the same problem, and I tried all above suggestions but unfortunately none of them works for me ... then I tried "Windows Live Mail Options" and I found the solution :)

1. Open your Windows Live Mail
2. Click on Tools / Options
3. Click on Connection Tab
4. Click on "Stop Signing In" button
5. Click Apply / Ok

Thats All ........ Have Fun

Here is the screen shot
http://tinypic.com/images/goodbye.jpg
Thank you so much, all the other information seemed complicated, download this, uninstall that. Sounded like lots of places to go wrong. You had such a simple fix that worked perfect. Thank you again.
YEHHHHHHHHHHHHHHHHHHHHHHHHHHH. I LOVE YOU.

Thank you.
Thanks Stevo it works well
i cant open my e mail box in hotmail apparently you can help me,thanx
I can not access websites from Emails..grt the message 'This operation has been cancelled due to restrictions in effect on this computer' I used to be able to ,but must have changed a setting inadvertantly, Can You Help?
thanks lot,,i've solved the error in first step,,without closing any explorer window.
thanks again
thats wot happens 2 me so do a new acount and let ya friends no!