Asus laptop wont connect to certain network anymore [Closed]

Report
Posts
1
Registration date
Wednesday April 22, 2015
Status
Member
Last seen
April 22, 2015
-
 Suyee -
Hi !! .. Okay, so I got myself a new asus laptop about 2 weeks ago. I brought it to work and connected it to my works wifi , as I always do with my phone as well , and everything worked perfectly. I was able to use the wifi for about 3 or 4 days when suddenly the next day it just wouldn't connect anymore. So I tried forgetting the network and reconnecting, but it says "verifying and connecting" and then "cant connect to this network" .. The password definitely hasn't changed, I can still connect to the works wifi with my phone and other devices, even when I forget the network and reconnect. And my laptop can also connect to other networks and hotspots, like my phone, my moms phone, the cafe's network, etc. So the laptops wifi does work, just not with the works network anymore.. If anyone has any suggestions or thoughts please ?? I would really appreciate it.And im not very tech clever, so please explain nicely so I know what your talking about :) ! Thank you.

2 replies

Posts
341
Registration date
Tuesday March 3, 2015
Status
Moderator
Last seen
July 3, 2015
59
try to unistall and reinstall your wifi adaptor
go to your asus website and download the wifi adapter driver
press windows button + R and type this command
mmc devmgmt.msc

look for your wifi adaptor

un-install it and run your downloaded driver to re-install it
Its not working. I Un-installed it and when I went to reinstall it wouldn't. So I connected my phone to my laptop, ready to move all my files to my phone In order to reset my laptop, but the adapter magically appeared again. And I definitely un-installed it. It still wont connect to the wifi though. Any other suggestions?
> Michane
Hi Michane! My asus laptop having the same problem with you.. May I know is your problem solved?
Posts
3587
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
752
Did you see any red x or yellow (!) exclamation mark near network adapter option in device manager if so then provide your laptop make and model!
nope, theres no red x or yellow ! ..........