WD my passport 1tb asking for format [Solved/Closed]

Nikhil Telkar - May 18, 2015 at 04:11 AM - Latest reply:  Ranjan
- Mar 20, 2018 at 03:50 PM

When I connect hard drive to my PC then it shows just blank (H:) drive and address bar shows content loading. I wait more than 15 to 20 mins but still it display as loading. so When I remove it, then pop-up loads like (you need to format before you use.)

Please help me on this, it will be great help-full...
See more 

24 replies

Computertech 3743 Posts Friday February 6, 2015Registration dateContributorStatus July 18, 2016 Last seen - May 18, 2015 at 05:50 AM
Hello Nikhil,
please try to ;

strart > run > cmd

than enter

after this, type this command; chkdsk k: /f than enter. it will check your disk file system and if it find a problem, will be repaired.

in the command parameter "k:" is your drive letter.

IT Technician
Was this answer helpful?  
thank you a big time .. it worked perfectly.
thanks for your helpful information. it solve my problem.
Thanks a lot, Computertech.
The solution can helps me fixed the problem for my WD 1TB passbook as well.
Thank you once again.

Rgds, Jeff
Thanks. This worked for me.
Hi, I owe you..I didn't even think of this until I saw you solution. I was so depressed loosing my files in the HDD. After running the chkdsk, it was able to read it. My extreme gratitude to you..appreciate your help
R2D2_WD 3616 Posts Monday September 1, 2014Registration dateCertified CCM ContributorStatus February 20, 2017 Last seen - May 19, 2015 at 10:11 AM
Hi Nikhil Telkar,

Could you tell what do you see in Disk Management? Is the drive shown as initialized, with drive letter and a file format? I strongly recommend you to try the device with another USB cable and on another PC. You could also try to uninstall your My Passport from Device Manager. Restart the PC and plug the device back in.

Hope this helps
R2D2_WD 3616 Posts Monday September 1, 2014Registration dateCertified CCM ContributorStatus February 20, 2017 Last seen > nikhil - May 20, 2015 at 03:13 AM
Enter Device Manager and search for USB Serial Bus Controller. Click the (+) symbol and you should see your device. With right click you should get the option to uninstall. Do not wary, the device should be reinstalled automatically the next time you restart the PC and connect the drive. You really need to check the device with another cable and on another PC.
Sorry for late reply...

I will try as u said, Will let you know once done...

Can I call you or from ur end can anyone call me on 09769425566 ?

That will be great help.

Thank you :)
It worked for me
Worked for me Thanks a lot