Massive USB failure

[Closed]
Report
Posts
1
Registration date
Sunday April 26, 2009
Status
Member
Last seen
April 27, 2009
-
 I phone frustie -
Hello,
Basically nothing plugged into my USB ports work. That isn't to say my USB ports are broken, the computer knows that something is plugged in (the option to safely remove is there whenever something is plugged in). I have lurked countless threads and forums searching for an answer to fix my problem. My iPod, usb flash drives, even my printer no longer work with my laptop.

So far i have tried uninstalling the USB hub roots and reinstalling them. I have also checked in device manager to make sure that this problem isn't simply due to a drive name not being assigned. When i checked in device manager with something plugged into my usb port, nothing shows up. I made sure to check disk manager as well, but nothing shows up in there either. And of course nothing shows up in My Computer. Plug and play is enabled so I can't for the life of me understand why nothing is working. Its extra frustrating because the computer gives me the option to safely remove but thats it. I can't access anything plugged in (flash drive) or update it (iPod).

The ipod when plugged in does show up on my itunes, but it doesn't show up under its name (Dinopod) Instead it is an unamed device. Also when it has shown up on my itunes, itunes says it is corrupt/ needs to be reformatted. This is odd because when my iPod is plugged into another computer it shows up as Dinopod, completely uncorrupt and a reformat is unrequired.

This whole ordeal has been very troublesome. I'd be eternally grateful to anyone that can help me fix this.

2 replies

Posts
21
Registration date
Wednesday September 17, 2008
Status
Member
Last seen
May 11, 2009
2
hi,
try to update the firmware of your laptop.
hope this solves your problem.

I 've the same problem. Figured out that when deinstalling I-tunes all USB ports work again. it seems that I-tunes identifies the USB ports as older versions than 2.0. Conclusion to me is that the problem is within Itunes. I can't find anything to fix this problem at the apple Support website.