My RCA tablet won't connect to WiFi [Solved/Closed]

Registration date
Friday July 22, 2016
Last seen
July 22, 2016
 kmb1979 -

My RCA tablet was not connecting to my Wi-Fi network. Assuming that it was damaged, I took it back to seller and got it exchanged with a new device. However, the issue remains the same.

Please help!

1 reply


I kept getting an authentication error when trying to connect to my WiFi even though I was connected to it till a few days ago.

My other devices were still connected too it. So, I knew it wasn't my router. Here's what helped me:
  • In the WiFi screen, I selected the menu icon.
  • Selected Advanced settings
  • Clicked on WPS push button
  • I pushed the WPS button on the front of my router and it instantly connected

Hopefully this helps someone!
Thank you

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 2942 users have said thank you to us this month

Thanks worked 4 me
I'm on a public library router access and I pushed the WPS push button and it says the WPS failed ....try again in a few minutes ? What else could be the problem. I'm showing a strong signal connection.
Registration date
Monday February 1, 2010
Last seen
June 2, 2021
10,431 > art
Your tablet is trying to connect to your home router.
Yes! This worked for me. I always have routine issues with our RCA Galileo Pro tablet disconnecting from WiFi, and no matter how many times I restart my tablet and router, it still says there is Authentication Problems!!! Then I remembered this advice -- you just go to Advanced WiFi, and then select WPS Push Button option, as well as pushing that button on your router, and it connects no problem!!

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!