Report

Folders/drives wont open, search window shows [Solved/Closed]

Ask a question K - Last answered on May 6, 2017 at 02:31 PM by Zebluve
Hello,

Please help, I'm not sure what happened but I can't open any of my folders by clicking or double clicking on them, none of my drives or external drives as well. It bring sup a window with the search prompt, as in how you would search a drive or search your computer from Windows. I don't have a save point to go back to an earlier time either... I can right click on start and explore and get to my files that way, but even clicking on folders not in the tree menu the search windows pops up.

Thank you.
See more 
Helpful
+213
plus moins
Click [Start] [Run] and type "REGSVR32 /i SHELL32" then press the Enter key.
sideshow ash- Aug 22, 2010 at 07:32 AM
I LOVE YOU!!!!!!!!!!!!!! MMMMAAAAARRRRRRYYYYYYY MEEEEEE??? PLZZZ
phantom- Sep 4, 2010 at 10:23 AM
cool stuff!!1
warrior- Sep 7, 2010 at 10:16 AM
imran-hey great dude.. really u r a genious
lea ramsey- Feb 24, 2013 at 09:58 PM
thank you so much!!
Zebluve- May 6, 2017 at 02:31 PM
Thank you so much, it truly took 3 seconds. A life saver!
Reply
Helpful
+21
plus moins
I suspect you have a virus problem. First thing to do is fix the double click problem. This might help

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\

3. type attrib -r -h -s autorun.inf

4. type del autorun.inf

if you have a d drive:
5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your immediate troubles will be fixed.

You will need to run a virus scan to find the program that started this.

Good Luck
abhi- Dec 9, 2009 at 09:00 AM
u r a genius man .. it really helped ... I had been messing up with the pc for long and finally u gave this wonderful solution ..thanks man
dumbell on PC land- Feb 2, 2010 at 06:02 AM
Having trigger finger and carpal does not help, you end up pressing the wrong keys or worse.... you become more depressed. I am sick and tired of looking at "SEARCH" instead of OPEN.. I tried your advice and it work asap. thank you for the solution to this problem . you're the "Robin Hood" of PC world. more arrow to you....
Curiousity- Sep 7, 2010 at 09:48 AM
its really works!!!!!!!!!!! thanks dude!!!!!
Helpful
+15
plus moins
You have to customize context menu for drive letters.

A Context Menu is what you see when you click the right mouse button on a drive, folder, file, application titlebar, or nearly any other object on the screen. Most of the time, this menu includes a list of actions appropriate to the object on which you've clicked.


Select Folder Options from the Tools menu in My Computer or Explorer, and click the File Types tab.

Highlight the Drivefile type, and click Advanced.

You can add new items, change the default action, and remove unwanted items here. Click Browse and find explorer program in Windows folder. select and approve it, specify it as the default action.
HXM- Apr 6, 2009 at 05:47 AM
Thank you, that was the best only answer that worked.
eliud kalokola- Sep 6, 2010 at 07:13 AM
yah man that was fantastic,it solved
Helpful
+11
plus moins
After you follow the steps in the previous sections, Search Companion may start when you double-click a folder instead of the folder being opened. Or, if you have associated other actions with file folders, those actions may be performed instead.

To resolve this issue, follow these steps:

1. Start Registry Editor.
2. Locate the Default value under the following registry subkey:
HKEY_CLASSES_ROOT\Directory\shell
3. On the Edit menu, click Modify.
4. In the Value data box, type none.
5. Click OK.
6. Exit Registry Editor.
basit- Aug 14, 2009 at 07:33 AM
Thanks Alot buddy...

I had accidentally changed my context menu's default option to Search...

Your post really helped me...

Regards,

Basit...
www.basit.co.nr
Em- Oct 21, 2009 at 11:13 AM
Hello Jeremiah,

Thank you so much for your help. I tried the other solutions above and none of them worked. You are a genius! You and others that offer assistance on these type of websites are lifesavers. Have a good day. :)
Hanbasilich- Jul 16, 2010 at 01:49 AM
Hello Jeremiah
God bless you for helping me sleep to night. For the past 3 days I've been worried over this problem. You solved it. Cheers.
Amalraj- Aug 12, 2010 at 04:16 AM
Its really v good it solved mt problume
Helpful
+6
plus moins
write the below command in your run window and press ok

regsvr32 /i shell32.dll
Helpful
+5
plus moins
thks ... its really helping me in solving my problem
Helpful
+2
plus moins
It's not working for me ... Not only is there a double click problem but even the menu items from task manager is lost :S I am in grave tension .. what should I do .. pleasee help me out here ... :( :'(
RACER4200- Dec 21, 2009 at 04:29 PM
Awesome! You saved me from further frustration!
Praveen- Jun 9, 2010 at 01:32 PM
Registry fix worked. Thank you.
Helpful
+2
plus moins
Thanks , it solved my issue
Helpful
+2
plus moins
thanks worked great

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!