Report

Can't transfer data from external hard drive [Solved/Closed]

Ask a question adamk1 1Posts Sunday September 8, 2013Registration date September 8, 2013 Last seen - Last answered on Oct 13, 2016 at 05:46 AM by Ambucias
Hi,

I recently started having problems with my external hard drive (Seagate Expansion 1TB), after 2-3 years of flawless performance. It started off having really slow copy speeds (kept dropping to around 3kb/sec), but my computer could read it and can show me what's on the drive (folders, files etc) however, I could not open them, copy them to the fixed hard drive or copy anything to the external hard drive. Now I plug it in and my computer has a bit of trouble reading what's on the disk, and when it can read it, there are some folders I can't even open (see error message below).

I get different error messages from both opening and copying files. For opening files/folders, I get:
---

E:\PC Backups is not accessible.

The request could not be performed of an I/O error.

---

Whilst for a copy/paste job, I get:
---

An unexpected error is keeping you from copying this file

Error 0x8007085D: The request could not be performed because of an I/O device error.

---

I've gone into a couple of PC shops where they told me that they had never encountered this problem before, but might be caused by a bit of dust getting on the disk itself and would suggest buying a new hard drive. I have also had a look at what error 0x8007085D is and it seems that it's a simple disk read error (most commonly due to smudged discs, according to the forums I've seen). I don't mind having to buy a new external hard drive, but I don't want to lose 600GB-worth of backups and important files I need.

Any ideas as to what could I do?

Many thanks

Adam
Helpful
+0
plus moins
Please try this:

This type issue could be caused by a USB virus. It will spread to all of your USB memory devices and hard disk.

Here is a tool to remove the virus and vaccinate your USB against further viruses.


Download UsbFix (created by El Desaparecido) on your desktop.

USB Fix

If your antivirus gives an alert, ignore it and temporarily deactivate the antivirus.
Plug in your usb devices (Flash drive, pen drive. External HD etc...) don't open them.
Double click sur UsbFix.exe.

Click on deletion
.
Let the tool work.

Ambucias
Moderator/virus security contributor

At the end of the scan a report will show which you can copy and paste here..

The report is save at the root ( C:\UsbFix.txt ).

You can also vaccinate against any virus.
SH2016- Apr 24, 2016 at 01:48 PM
Hi,
I have the same problem and I have installed the USBfix. it doesn't work on my mac. Appreciate your support!
saraholsan 1Posts Sunday April 24, 2016Registration date April 24, 2016 Last seen - Apr 24, 2016 at 03:49 PM
Thanks man
Pranab- Jul 30, 2016 at 01:57 AM
Hey it worked.. Thanks
Pinky- Oct 13, 2016 at 12:20 AM
Does data get deleted when you the usbfix ?
Ambucias 46718Posts Monday February 1, 2010Registration date ModeratorStatus November 15, 2017 Last seen - Oct 13, 2016 at 05:46 AM
No

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!