Report

Acer laptop will only connect with full strength wifi [Solved]

Ask a question James Fitzgerald - Latest answer on Sep 15, 2016 10:58AM
Hello,
My acer laptop will only connect to wifi once it's close enough for full strength as soon as it goes down in strength it disconnects
See more 
Helpful
+0
moins plus
Hey there James,

I think, it's pretty normal to disconnect your laptop from the network once there's no wi-fi signal.
Please, explain with more details the problem that you have with the wi-fi connection. Also, please share some info regarding where is the access point for the network you plan to connect to and have you made any changes to your laptop recently.
If there's a need for driver update of the network card, please, do so. You can do that by connecting the laptop directly to the Internet via Ethernet cable to your router/modem or use the strongeсt wi-fi signal to do the job.

Let me know how it goes.

Add comment
Helpful
+0
moins plus
hey so the network i usually use is my home network and it says that i can connect to it but unless i am sitting right next to the router it wont connect and then when i move away from the router it disconnects again and i know its not the router itself because i have other devices that are connected from further away. i havent made any changes recently but it has asked me to update to windows 8.1
how will i know if i need to update my network card?
cheers
KY_WD 1703Posts jueves, 23 de octubre de 2014Registration date Certified CCM ContributorStatus November 23, 2016 Last seen - Aug 17, 2016 11:05AM
Hello again,

Since you said that other devices in your house can connect to the router from the distance then there's another thing we could try. Check the settings of the card, I mean the channel that the card is working at. Try this:
Go to Control panel> Network and Internet> Network connections and in the properties of the network card click on Configure>Advanced. There you must tell me /or attach a printscreen/ what is the value that you see in the first two options in Property. Are there the 20 MHz only or the setting is set both on the 20MHz and 40MHz.

Cheers.
Reply
James- Sep 15, 2016 03:36AM
Hey sorry for the late reply can't attach the photo but in the property section it goes,
802.11b preamble
Adhoc 11n
They're the first two things is this what you meant?
Reply
Add comment
Helpful
+0
moins plus


So I figured it out this is the screenshot
KY_WD 1703Posts jueves, 23 de octubre de 2014Registration date Certified CCM ContributorStatus November 23, 2016 Last seen - Sep 15, 2016 10:58AM
Hey,

It depends on the network card, but yes. Check the values of the second one as well. If there is an option to change it to lower frequencies, you try setting it to see if it will work. If not, set it to the original values again.
Rereading your second post, you said that it required you to make an update. Prior to this, please, make sure you have a backup of your important data on an external place just in case.
After the update has completed, come back to tell me what happened.

Cheers.
Reply
Add comment

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.

Not a member yet?

sign-up, it takes less than a minute and it's free!