Computer Turns On But No Display and CPU Fan doesn't Spin [Solved/Closed]

jei_kobu 1 Posts Tuesday September 12, 2017Registration date September 12, 2017 Last seen - Sep 12, 2017 at 04:06 PM - Latest reply: SSelva 2 Posts Wednesday September 20, 2017Registration date September 20, 2017 Last seen
- Sep 20, 2017 at 05:34 AM
Hey everyone,

I've recently had problems with my pc that I can't seem to fix.

Whenever I power on my PC, the case fan turns on and starts spinning as well as the green light on the motherboard turns on when i turn my psu on. However, there's no display on my screen as well as the cpu fan doesn't spin. There's also no beep upon startup.

I took the RAM sticks out as well as switched them in the slots but the problem persists.

I also unplugged all wires with my PSU turned off and took out my CMOS battery for 15-30 minutes yet nothing changed when i put it back in. I even reinstalled the psu, motherboard, and all of the wires yet nothing happened.

I just recently ordered a new PSU and motherboard within the last 2 weeks thinking they could have been the problem seeing as before with my old setup, my PC would stay on for 5 minutes then turn off without rebooting.

Here are the new motherboard and PSU models I ordered:

psu- Corsair CX550 550W ATX12V 80 PLUS BRONZE CERTIFIED ACTIVE PFC POWER SUPPLY

motherboard- ASUS M5A97 r2.0

Any help would be amazing!!
See more 

1 reply

SSelva 2 Posts Wednesday September 20, 2017Registration date September 20, 2017 Last seen - Sep 20, 2017 at 05:34 AM
0
Thank you
Check the connection wire between the monitor and base unite
--