Windows 7 Install - Cannot Find DVD Driver

Solved/Closed
DaParson - Oct 22, 2009 at 11:16 PM
 b3wii - Jun 29, 2013 at 08:29 AM
Hello,

Started a Windows 7 - fresh install - on a Gateway Quad Core Intel Computer - Presently Running Vista 32. All goes well - but then message comes up, "Cannot find DVD Driver" - with a Browse and Rescan Option. I exhausted all searches Harddrive - do not have a DVD Driver Disc - what are my options? Other than to buy a new DVD/CD Drive that is Windows 7 Compatible. DVD Drive was fine in Vista 32. Help?
Related:

17 replies

After reading many threads in many places and trying just about everything I saw (removed HW until almost nothing left, reduced BIOS settings to minimal items, good quality ISO burn, booth from USB, etc.), I was finally able to resolve the problem on my system and it had nothing to do with the DVD drive/drivers at all (I had even removed all IDE components), it was the SATA drivers for the MoBo.

On another PC (obviously), I downloaded the latest Win7 drivers for my motherboard and put them on the USB stick that I was installing Win7 from (although this should probably work even if you install from DVD, just as long as you can get to them when you Browse from the error dialog). Once I got the error, I browsed to the files to install, but they still didn't show up. I unchecked the box for not displaying incompatible drivers and then they showed up. I selected the driver and hit Next and everything went smoothly after that.

What drives me crazy is that the error message gets you looking for DVD drivers when it has nothing to do with that, plus Win7 doesn't even recognize the correct drivers as being compatible with the hardware!

Anyway, after several days wasted at least my system is up and running finally. Hopefully this will help resolve the problem for others as well and save them from wasting as much time. Good luck!
188
just replace your dvd rom and it will be fix
0
It may be your embedded raid controller. Delete your logical drives in the setting option 2. This takes away the raid controller driver and uses JBOD that window will definatly recognize
0
I have downloaded an updated chipset driver and placed it on a USB stick. After unchecking the display incompatible drivers box, I still cannot see the driver, only folders which are on the USB. How do I see the driver that I downloaded? The file is a .exe file; do I need to execute it on another computer and then somehow copy the files?
0
OK now is the truth. This is the solution.

I assume all of you is using USB drive to install.

When Windows is asking for driver, just click Cancel. You will be brought back to the welcome screen. At the welcome screen, remove your USB drive, insert it back to DIFFERENT USB PORT. Click Install Now again. The installation process will be like usual.

This problem happened to all new version of updated Windows 7 installer. I think, it is due to failure of Windows installer to remain its detection to the USB drive. It lost the connection, and became confused, don't know where to find the USB drive it used to read before.

When we re-insert the USB drive, Windows installer will detect the USB drive back, and continue like usual.

Good luck and cheers! TQ.

http://www.tomshardware.co.uk/forum/14831-63-windows-driver-install
0
thx you
0
hi
try 2 install win 7 from usb flash memory by using |Windows7-USB-DVD-tool| relased By Microsoft
18
use dvd+r, or +r DL ......i dunno why but this has solved my problem.....dvd-r doesn't burn right
15
To fix the problem that dvd drives are not recognized in Windows 7 permanently do the following:
1. Press Windows R, type regedit and press enter.

2. Open the Registry key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

3. In the right pane, right-click UpperFilters, and then click Delete.

4. Click Yes to confirm the removal of the UpperFilters registry entry.

5. In the right pane, right-click LowerFilters, and then click Delete.

6. Click Yes to confirm the removal of the LowerFilters registry entry.

7. Exit Registry Editor, and then restart the computer.

If you need more assistance on this, contact http://www.247techies.com/ for immediate Microsoft tech support
14
i have been seeing this method for awhile the problem with my computer under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE1031"
file I don't have upper or lower filters.

Do u have any other opinions?
0
I read about this method in the official magazine of Microsoft but didn't work for me. It crashed my laptop. And can't find UpperFilters and LowerFIlters both together.
0
Hi Mike,
Thank you so much for this info, It has fixed my problem-- I have my dvd shown --- so I have it back. I am a 69 years young and thought I could not do this but followed your instructions.

Once again thank you so much.

Regards
0
Your procedure works fine ! Thank you for share your knowledge with us.
Paulo _ Brazil
0
thanks, This worked. I have this problem on a Lenovo laptop and a Dell Studio desktop,\. The Lenovo is working and now I'll try it on the Dell. Must have been the last win7 update I'm guessing.
0

Didn't find the answer you are looking for?

Ask a question
I dealt with Microsoft on this and they had no clue. I agreed to help and we spent three days one hour here and there trying all sorts of things like BIOS settings among other various fix it applications through Windows.

What I told them and is true with most of you I bet, keep rebooting the PC and pressing any key. Eventually you will get a proper boot of the install disc. I know because I have done this twice, if you try 5, 6 or more times in a row eventually you will get the disc to run.

A Side note: If you want to reformat like I do you have to get the disc to load on bootup. I did get the disc to run twice while the OS was running but when I got to the install on which partition part I will use they would not let me reformat. The Advanced button simply was not there.

If you reboot your PC over and over I bet you get it to run. This is not ideal but I am sure Microsoft is working on it as they told me so after helping them. It is a temporary workaround if you need. Good Luck.
10
Hey Yoda....I seem to have the same issues. Kept rebooting just out of frustration, expecting nothing, then hey...a reboot!
0
i thought it is stupid idea but after 4 reboots, cd dvd driver message did not apper and windows are installing at this moment. hopefully there will be no more problems during the instalation. I would go crazy without your solution, thanks!!!
0
Did the same thing. Rebooted a few times. Still didn't work. So, I switched my laptop off. Removed the power cord from the wall socket and waited 1 minute. Then it found my DVD drive and I'm able to format my laptop. By the way my laptop is 1 week old. Came with Windows 7, everything is fully compatible but still Windows 7 messes with my DVD like all you guys. When Microsoft launches a new OS it always have bugs and then the work on Service Packs which we need to download. Thanks for the comments anyways.
0
I'm trying to install Windows 7 64-Bit on a HP Workstation, XW9300 and the system does not recognize the DVD disk as a bootable disc. I can install XP 64-BIT no problem, if this is a BIOS issue how do I resolve? Anybody help!
8
I have Asus g50v, windows 7 32bit When installing with my language russian I have this problem. with my language english all functions well work
0
I had the very same problem and the solution is:

1,You have a limited chipset on your motherboard that can not address/remap 4GB of ram properly what you have to do is remove one of the memory sticks and install windows using just 2GB.

2,Or if your chipset/bios supports it enable memory hole remapping in bios setup.

Yes I know its has nothing to do with a DVD drive but trust me this works if it was a faulty cable the disc wouldn't have booted to begin with

I was running 4GB of ram on an AMD 480X Chipset this is one of those limited chipsets

Intel also has chipsets that cause the same problem.
6
Tried your first solution Rick. It's a no go on my Intel G41 chipset.
0
I was having the same problem using an old emachine case and the original DVD drive, but the board is new, so I took out the dvd drive and replaced it with a different (newer) one and the install of win 7 went perfectly! Hope this helps.
6
Have successfully used option 2:

http://capitalhead.com/...

good luck.
5
Thanks, guy. I resolved my problem. Thank you very much.
0
Thanks so much. The second method fixed me right up. Tip of the hat to you...
0
Azam Jauhari Apr 19, 2010 8:05am BST
I encountered this problem when installing Windows 7 x64 on VMWare, and found some suggestions that the problem might be from a bad disc burn, so I tried to install directly from the ISO image, and true enough, this time it installed successfully



Just as stated above....use alcohol120 and run the win7 setup from the ISO itself. :) IT WORKS!!!!!!
3
I encountered this problem when installing Windows 7 x64 on VMWare, and found some suggestions that the problem might be from a bad disc burn, so I tried to install directly from the ISO image, and true enough, this time it installed successfully.
2
A simple fix, make sure you have less then 3gbs of ram in your comp during install. I tested with 4 gbs got the cd/dvd driver msg, then tested with 2 gbs worked fine. Tested again with 6 gbs and failed. Hope this may help some people. worked for me.
2
tried removing 2 of my 4 gbs of ram - no difference. so far, only repeated retries have worked for me - have been struggling sith this a few times since release of win7, still havent found a solution - I keep fiddling with it based on searches and eventually I get there.
0
Hi am having the same problem but am using a flash drive to boot any solution on this am usein asus notebook I really need help with this problem
1
hahah

Just check your Cd/dvd drive if jumper is set to Master or Slave . And work

if it not set to Master or Slave installer not work!!!
0
closeup22
Posts
8924
Registration date
Friday May 15, 2009
Status
Member
Last seen
October 7, 2010
2,109
Oct 24, 2009 at 11:20 AM
hi there,

open your cpu

and change the ide cable

or in bios check if its detected or not

Thanks
-7
guys, you should just get a original copy or at least make a decent burn :)
-16
good comment blockhd

im going to install this in this next day or so ill let you know if I have this dvd issue
0
look you cocksmoker, many of us actually do have original versions but are having this issue.
0
I have the original and the problem is here.
0
i used a genuin Windows 7 disc and have the same problem - Asus X5DIN notebook. I was advised to go to BIOS and change to manifacture settings. As I am not that good at technical stuff I am not sure what this is going to do for me. Will do some more reading on the net before attempting this
0
FWIW I solved this problem by mounting iso with mac Disk Utility so it looks like a hard drive.
0