Cannot connect to iTunes Stores

Solved/Closed
tpx400 - Mar 4, 2010 at 07:40 PM
 momo - Mar 11, 2013 at 11:48 PM
Hello,
Since I downloaded the latest iTunes version, I started to have connection problems to iTunes Store. I tried everything already including adding iTunes to the McAfee exceptions, the use of Proxy Server has always been unchecked, reinstalled iTunes, etc. but so far still no luck. It keeps saying Loading... when trying to connect to the Store and when trying to update my applications, it says to check my Internet connection. My internet works perfectly fine. I don't have Norton on my PC, so that is not a problem. HELP!!!
Related:

7 replies

Same here. I have tried pretty much everything that the Apple site said to do. :/ I don't have Norton either and my connection is working. I have reinstalled iTunes twice now. Nothing is working.
112
Not sure what is going on. There must be somethning wrong with the latest iTunes version. Apple better fix it in the next release. They are not getting any business from me as I can't connect to the store.
0
thanks a lot it works great again
0
huongsir
Posts
6
Registration date
Wednesday March 24, 2010
Status
Member
Last seen
March 24, 2010

Mar 24, 2010 at 07:55 AM
Hi,

First, thanks you for answering the question.

I have same proplem, but I don't know where to tick to "allow access to iTunes U"

I tried to find iTunes U on itunes, but I cound not find it

Anybody help me where I find it? (steps )

thanks!
0
huongsir
Posts
6
Registration date
Wednesday March 24, 2010
Status
Member
Last seen
March 24, 2010

Mar 24, 2010 at 10:17 AM
Oh well,

It worked for me

thanks !
0
HUONGSIR----

Open your iTunes....
go up top to the EDIT tab....
then at the bottom of that tab is a choice for "Preferences"...
then a box will open up...choose the "Parental Control" tab at the top of that box.....
then click on the Itunes Store and the Itunes U....
now follow her instruction above and you'll be set!
0
I found this on another site and it fixed my problem:

Opened iTunes. Clicked on Preferences and under Parental Controls disabled access to the iTunes Store. I then checked the box to allow access to iTunes U.
When I tried loading the store this time, it sent me directly to iTunes U with no problem.
I then went back into Preferences and enabled access to everything and tries reloading the store.

Voila. I can now connect to the whole store with no problems. Strange
76
Thanks!! This worked!! Really appreciate the help.
0
thanks you saved me !!! strange how that works
0
Thanks for this!!! have been hunting for a workaround
0
Excellent. I had a similar issue and this solved it. Thanks
0
Thanks, this solved my problem. I could have never figured this out. Thanks again
0
I fixed this problem by going into start/internet/internet properties/connections/Lan settings and then un=checking "use a proxy server for your LAN.

No other issues as a result of unchecking this.
24
InternetLover
Jun 5, 2010 at 05:19 AM
YES, Thank you so much. The un-checking proxy server method worked and spared me a lot of frustration!!
0
well in....spent days on this.....thanks so much....now works a treat
0
thank you! it worked!!
0
Thank you - worked like a charm. I was using firefox that was connecting to the internet and never use IE but had to uncheck on IE too for it to work.
0
Thank you ;)!!!!
0
No chance.
i have a router-based firewall (whitelist) and even after adding all four addresses as http as well as https as "allowed" I still cannot connect with the itunes store...

Latest itunes, downloaded and installed yesterday...
12

Didn't find the answer you are looking for?

Ask a question
travel princess
Apr 21, 2010 at 08:58 AM
Amazing - thank you!!
hugs - :)
9
try this

Open iTunes.
On Mac OS X: From the iTunes menu, choose Preferences.
On Windows PC: From the Edit menu, choose Preferences.
Click the Parental Controls tab.
Place a checkmark next to the option to disable the iTunes Store, and next to the option to Allow access to iTunes U
Click OK.
Open iTunes preferences again.
Choose the Parental Controls tab.
Remove the checkmark next to the option to disable the iTunes Store.
Click OK.
Test the issue.
If resolved, it is possible the issue may return in the future. Look for updates to this article or apply future iTunes software updates for a permanent resolution.
6
i disabled the iTunes store..but there is no option to allow access to iTunes U. What is that? My parental controls only lets me restrict access to things..help?
0
never mind it worked after all! I just needed to update my iTunes!
0
Me too, tried for weeks with alsorts of complex ideas. Thanks a lot, I can get some noo toones,
0
thank you this worked :)
0
holy crap that actually worked! Thank you!
0
Vasim Padhiyar
Apr 6, 2010 at 04:04 AM
how can I login to itunes connect using remote php script ?
0