All drives are not open by double click & win [Solved/Closed]

- - Latest reply:  PaSTie - Apr 3, 2014 at 11:04 PM
Hello,
My PC having four drive & it is not opening with double click & showing open with programm,even same error is showing when opening with explore.OS is XP.

Regards
Rajesh
See more 

20/22 replies

Best answer
Posts
19519
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
December 14, 2018
45
Thank you
Virus trouble

Sometimes it happens in windows XP that you are not able to open drives on your hard disk. When you double click on the drives icons or right click on the drive>>explore in My computer ,the drive does not open.

This problem is generally caused by most of the viruses which infect windows XP system. They block or restrict your access to any of the drives.

But don't worry this is not a big trouble it can be fixed easily.

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\

3. type attrib -r -h -s autorun.inf

4. type del autorun.inf

5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your trouble will be fixed.

Say "Thank you" 45

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2750 users this month

Great . Thank you
Thanks, My drives didn't open by double clicking,however opened with -run-explorer drive: you saved the day thanks again mate
Thank you very much . Issue is resolved in my PC. :-)
when I open my drives, show me a msg "restriction with administrator" whereas i'm in an administrator's drive...!
plz send me an answer :(
Posts
10
Registration date
Friday January 30, 2009
Last seen
March 1, 2009
13
Thank you
Very simple . virus create some bad registry if you want to solve this problem then delet this registry


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2


delete all drive from here
I want to thank you for this superb read!! I certainly enjoyed every little bit of it.
I have bookmarked your site to check out the latest stuff you post.
http://www.oaktree.com.au
I want to thank you for this superb read!! I certainly enjoyed every little bit of it.
I have bookmarked your site to check out the latest stuff you post.
http://www.electricians4u.com
thanks you sooooooooooooo muchhhhhhhhhhhhhhhhh
thanks problemssolved my
ty ty ty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
10
Thank you
Hello,
My PC having four drive & it is not opening with double click & showing open with programm,even same error is showing when opening with explore.OS is XP.
6
Thank you
Hi everyone, I have the same problem when I open My Computer then double click one of my drives (c or d) it opens up an image program (ACDseePro) instead of expolring it, I have to right-click then open or explore.
I have tried the command prompt ( autorun.info) but file was not found in any of the drives , I also tried gpedit.msc and enabled autoplay but it didn't work. Used Spybot serach&destroy, Flash-Disinfect, Disc-Heal, Fix-Drive and did a virus scan with NOD32 but nothing was found and the problem still persists!!!!!!!!!!!!!

Please advice
5
Thank you
Hi,
Super. nice trick. thank you
hi buddy thanx very-very -very much its working 100% without any problem. it save my importnat data to open
thanx once again itz a very good fix. awesome.thanx
still not working .... please provide me a better opinion about this severe problem which I am facing....
4
Thank you
sir ur a genius thanks
Thanks a lot sir, it worked.
Mike Belly
http://losebellyfat101.org
2
Thank you
Thanks for the info and solution that you have shared...
keep it up, more power and knowledge...
2
Thank you
Thanks it work fixall ,all others mention in this replies, didnt work for me.
2
Thank you
Thankyou boss my problem is now resolve
1
Thank you
thanks it worked for me! ^^
-
this is something that I should have found a couple of months ago.anyways thank for such a wonderful post.
What a great article.. complete with the + and - . Yup.. it's very useful. Thanks
http://www.myinsurancemaster.com
1
Thank you
thanks allot
1
Thank you
Thank you so much for guide me
1
Thank you
Thanks alot Pal from all the way in Jamaica! Jah Guide...
1
Thank you
I m unable to open my drives with double click on it nd its giving the msg open with.....
i tried the autorun delete option also but I typed attrib-r-h-s autorun.inf but it is not reconizing it . heilp me
1
Thank you
regsvr32 /i shell32.dll
OR
HKEY_CLASSES_ROOT\Directory\shell none
0
Thank you
Dear Sir
i tried your solution and it worked and I just want to thank you........
thank you very very much and God Bless U...................................
0
Thank you
I have a simuliar problem, but can't type the command attrib -r-h-s autorun.inf ..my computer doesn't recogize it, I tried various other ways in format it, no luck. I have windows xop any ideas?
after typing -r give one space then repeat the same for -h and -s , mean give one space between all
Posts
19519
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
December 14, 2018
0
Thank you
First you type cmd and enter

Then type

attrib -r -h -s autorun.inf without a space between the minus sign and the following letter but a space before the minus sign - this makes the file visible and allows you to delete it later. If DOS returns "file not found" it means the autorun.inf file is not on that hard disk.
> Frozen -
Thanx dude....
> Frozen -
dude u r great it solve my problem too
Thanx dude........
this trick has solved my problem.
thank u very much.........
Many Many thanks dear for posting this useful information....
http://www.removalists4u.com.au
0
Thank you
hard disk drive is not open
Virus trouble

Sometimes it happens in windows XP that you are not able to open drives on your hard disk. When you double click on the drives icons or right click on the drive>>explore in My computer ,the drive does not open.

This problem is generally caused by most of the viruses which infect windows XP system. They block or restrict your access to any of the drives.

But don't worry this is not a big trouble it can be fixed easily.

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\

3. type attrib -r -h -s autorun.inf

4. type del autorun.inf

5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your trouble will be fixed.
I use win xp pro. I had an autorun virus which blocked opening of the drives. I ran the program flash disinfector and the virus problem was solved. but from my dvd drives, no cd/dvd starts on its own unless click the dvd-drive icon. how can I get back the 'autorun'? I changed shell detection using gpedit.msc, enabled autorun from properties..nothing works. Can anybody help?
hai this is nag. iam suffering from this problem since a month. n finally solved my problem. thanx a lot yar.
0
Thank you
PERFECT SOLUTION It magically worked for me

Pradyot
1 2 Next