ASUS laptop does not power up

Solved/Closed
sarah - Updated on May 24, 2018 at 03:32 PM
 Frank - May 21, 2018 at 04:28 PM
Hello,

Hoping someone can help:

My ASUS A6403KM notebook does not power up. When I turn the power on the lights come on for quick second and then automatically shuts down. Ive tried taking the battery out and then turning on same thing happens. Ive also tried taking battery out and mains and pressing power button 3 times (as per ASUS support center advice) and replugging in mains power and still same problem. ASUS service centre suggested montherboard needs complete removal (he is 99% sure did not open the laptop or anything! - very pricy this option). Im hoping someone can offer some alternative advice on what they believe the cause is or how I can reticify the problem.

Thanks

Sarah

27 replies

I had the same thing occur with my Acer 5520 Notebook. The green charge light was on but when I pushed the power switch nothing happened. I did some research on the internet and this is what I did that solved the problem:

I removed the battery and unplugged the power supply. I then held down the power button for 45 seconds. I then reinstalled the battery and the power supply and pushed the power button and voila it worked. I did have to try it a couple of times before it woorked but all is well now.
547
Thanks,
you were right. The standard 20 seconds listed on the ACER website didn't do it. Thanks for taking the time to post.
Jon
0
Thx a lot dude !!!
Works fine for me
Unplugged the battery and the supply during one minute the plug the battery and the notebook works fine :D
:::Asus 71SL:::
------------
0
OMG! It worked! :D
My Asus X51R has been refusing to boot for about 3 months now due to "CMOS Battery Low", "CMOS Corrupt" and "CMOS Date/Time Not Set", and I have been unable to do anything due to both the F1 (continue) and F2 (Setup) asked for a BIOS password that I never set.

None of the default BIOS passwords I tried worked, and I had quite honestly given up hope.

But after following your instructions (holding the power button without any power source connected for 45 seconds), it now boots up perfectly.

The F1/F2 alternatives still appeared the first time I booted it, but without password requirements.

You're a lifesaver :)
-1
The 45 second works!!! It's alive!!! It's aliiiiiiiivreee!!!! X
-1
Thank you SOOO much for posting that fix!! I was so afraid it was going to be an expensive problem. Your solution fixed it perfectly! Thank you!!!
0