Kingston 64 GB DataTraveler Pen Drive [Solved/Closed]

Report
-
 Sandy -
Hello,

I bought a pendrive 64 GB, when i put it on the PC, It recognizes the usb pen drive, but the only option it is giving me is FORMAT. when i click on it , it says can not be FORMATTED.

Its a new Kingston pen drive I bought from Hongkong from one Mall. And I haven't been able to use
this pendrive once also. From the day I bought it, its not usable.

Is there any way or any other software to format the pendrive and the pendrive will start working?

Important Information about Format screen :

When the format screen comes it shows as follows :
Capacity : 8.00 MB
File System : FAT
Allocation Unit size : Default allocation size

Quick Format Option is only available and when I choose it. It says "Windows was unable to complete the Format".

I will be glad and very happy to hear your suggestions.

I will be also very thankful to you if you can help me out.

Configuration: Windows XP-SP2, Internet Explorer 6.0

1 reply

Posts
8926
Registration date
Friday May 15, 2009
Status
Member
Last seen
October 7, 2010
2,063
Hi there,

You can make a try with hp disk formatting tool,you will get it for download on link below:

https://ccm.net/download/download-127-hp-usb-disk-storage-format-tool

Thanks
3
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

it worked on my 256gb kingston udb pendrive thank u so much dude
Hi closeup22,

Many Many thanks, this software is very good, after installing software the drive is formatted...

Thanks

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!