Ipod touch not working at all!

PagansmindFan Posts 1 Registration date Wednesday October 6, 2010 Status Member Last seen October 6, 2010 - Oct 6, 2010 at 10:13 AM
 Blocked Profile - Oct 8, 2010 at 02:11 AM
my iPod touch 1g will not work at all. Ive tried everything (holding down the on/off button and home button for 10 seconds everything possible ive been on the apple website for ipod touch troubleshooting, ive even taken it to an apple store they said the battery needs changing they advised me to take it to a repair shop and they will fix it for me. I then found out i could change the battery so i did, i got someone i know who specialises in wiring and on the battery packet it says that i have to keep it charging up for 3 hours, ive done more than 3 hours, yet nothing is happening.
Please does anyone have any suggestions on how i could get it working again without having to fork out money to buy a new one.

1 response

Blocked Profile
Oct 8, 2010 at 02:11 AM

Normally, the problem should have been solved while getting it restored to factory settings but the problem has been sourcing from its battery and this is why you have not been able to have it properly restored.

What you should do now is getting the battery charged but it is not charging even after having let it for some three hours. Try recharging it through another method, get it connected to a high power USB port. This should get it charged enough. Make sure that you do not use a port which provides low electric charge.

This should charge the battery and hence as soon as it is completely charged, have it restored to factory settings through the below instructions.


If it does not work, please tell.