No sounds with itunes and vista [Solved/Closed]

kittykermit - Jan 14, 2009 at 10:41 AM - Latest reply:  Me
- Aug 2, 2010 at 04:13 PM
Hello,

I too am having same prob as a lot of users. I downloaded Itunes 8 yesterday and listened to some podcasts with my headphones. Today when I logged on I can't listen to the radio online (via real player) or listen to my itunes library. I have VISTA Basic and think there is an issue with it and itunes 8 as my itunes worked fine before I upgraded.

I know it is working as a) I get start up and close down nose b) in control panel my sounds are fine c) audio in bottom toolbar on screen is set fine and the killer... when I d) plug my earphones back in I can hear my itunes playing fine!! And the display visually moves in time to the music.

All very odd. I have a Dell Insprion 9400. So I don't think it is a sony issue as some users think.

Anyone know how to solve this?

My itunes 8 said it didn't load properly - vista issue I suspect. So I cam considering re-loading again and seeing if it works. I wonder if it's cos I allowed it to use the Genuis tool to access my music and recommend new tunes?

I use firefox and vista and had to download a itunes plug in yesterday to make real player work.

Has anyone else solved this - it's sooooooooooooooooooooooo annoying....l!?

Help!!
See more 

6 replies

Best answer
1
Thank you
I had the same problem...I use Windows Vista Business 32-bit. I downloaded the latest version of DirectX and the problem went away.

choo_chu

Thank you, choo_chu 1

Something to say? Add comment

CCM has helped 1678 users this month

choo_chu

RE: I had the same problem...I use Windows Vista Business 32-bit. I downloaded the latest version of DirectX and the problem went away.

Thanks Choo-chu!!! Downloaded the latest DirectX and iTunes works just fine now. Man, I was trying everything but getting nowhere fast. Thanks for sharing. It works!!!

Dave
kittykermit - Jan 14, 2009 at 11:04 AM
0
Thank you
Hey guys - I think it maybe solved! My flatmate noticed it worked with headphones in and so slowly took that out of socket and it clicked into playing! So maybe it was just a loose connection? Worth trying as all other settings appear fine!

K
0
Thank you
I think your right, the new itunes and vista aren't working right together. I have the same problem music through headphones and no sound anywhere else. This is really annoying
0
Thank you
Hi, Have you checked your Security set up is clear to permit radio (or any other site for that matter). First bring the site you want to monitor onto screen in Windows Internet Explorer. On the TOOL BAR, select TOOLS - INTERNET OPTIONS - SECURITY tab. Left click on TRUSTED SITES and then SITES. Your site should be in the box marked 'Add this website to the zone.' If not, copy and paste it into the box. Click on ADD and all should be well - I hope. It worked for me. Note, if the site is not accepted, clear the box marked 'Require server verification (https) for all sites in this zone.' Remember to tick the box on completion, (if you want).
Pouyri
0
Thank you
i accidently deleted one of the audio files from my computer now i can't hear music on my itunes or windows music player..how can i re install it?