HDMI doesnt show up as playback optional [Solved/Closed]

- May 18, 2011 at 08:45 PM - Latest reply:  Opp
- Jul 6, 2017 at 10:16 PM
Hello,
I've been reading through all of your forum questions and have not found my problem solved yet, so I'll try asking. I've been watching movies on my laptop but playing through an HDMI cable on my tv, laptop sound worked on tv for the last month but doesn't now. I have tried going through control panel and changing speaker option to "HDMI" but the option to choose HDMI was not there. Then I right clicked my speaker in bottom right corner and clicked on "playback devices" and again the HDMI option was not there. It just has "Speakers: Realtek High Defintion Audio" and "Realtek Digital Output". Any help is greatly appreciated!
Thank you.
See more 

11 replies

Best answer
2
Thank you
I had to disable the Intel Display Audio driver under Device Manager > sound, video ..., restart the computer, and then re-enable it. This caused the playback device to appear in the playback devices list (control panel > sound > audio devices), and then select it.

Thank you, kjhf 2

Something to say? Add comment

CCM has helped 1655 users this month

Posts
1
Registration date
Saturday December 31, 2016
Last seen
December 31, 2016
- Dec 31, 2016 at 04:43 AM
I need to to the same, only click on "sleep" and then wake up, not restarting, but still hassle to do it on daily base, or even more time daily as when my PC locks the screen, the HDMI device from sounds disappear (both SHOW DISABLE & DISCONNECTED DEVICES are switched on).
I am afraid it will cause some issues to my PC in long term. Hope to hear some permanent solution from any of you.
Ta
-1
Thank you
For me I had to revert the controller to a previous date. It worked fine and hdmi appeared in the the devices...
-3
Thank you
Try reinstalling your audio realtek drivers for your PC.
Uninstalled and reinstalled. Still nothing.. More ideas? In case there's any confusion, my laptop speakers work great and sound runs through them fine, which is the problem. The sound is playing through my laptop speakers and not my tv speakers.
thank you for all your help! I losing my mind trying to listen to movies through the little speakers on the laptop!
i have the same issue, the only way I have gotten it to work is by shutting down my laptop and plugging the HDMI into both my TV and Laptop and then turning it back on. Im looking for a permanent solution because this is a hassle to do every time.
-8
Thank you
Next guess would be to adjust the format of your speaker output. By format I mean the frequency. You can simply do this by >opening the realtek audio manager > going to "Speakers" tab (if not there already) > then going to "Default Format" tab > and set the lowest (48000Hz) format and I think it is 16 bits. If these settings work then try moving down the list and selecting the highest that your TV can handle. If this all works plz tell me. Have fun!!
-22
Thank you
Here is what worked for me because I have been trying to figure how to work the audio from the computer to the t.v. for forever! Go to your realtek digital output option in the sounds playback option. Make sure your hdmi chord hooked up to your computer and t.v....next right click your realtek digital output option and click the test button inwhich you should hear a jingle on your t.v, and then click play on whatever you want to watch on your t.v. It should play the audio now. Hope it works for you!!