No sound on LCD TV - Desktop HDMI connection [Solved/Closed]

- - Latest reply:  krishan lattala - Nov 11, 2017 at 04:44 AM
Hello,

I have a really annoying problem, and I hope that someone could help. I've already googled it, but none of the normal suggestions for this problem solved it.

I've connected my desktop (windows vista, ATI 4770) to my Samsung 37" LCD TV trough a HDMI 1.3 cable.
The video is excellent, but there is no sound coming out of my TV speakers. I've set my desktop sound device to "High definition audio", the sound device added to my computer after I installed the 4770 graphics card (so I know the graphics card supports sound), but nothing.

The sound in other HD devices I have works just fine with only an HDMI cable. I've tried all 3 HDMI connections in my TV, but with no success.

Thanks a lot for any help or advice!! this thing is driving me crazy...

Michael.
See more 

8 replies

Best answer
approved by Jean-François Pillou
484
Thank you
Hi guys,
I had the same problem like many of you. I'm using Vista OS, Acer laptop and Hitachi TV.

Solved:
  • After connecting go to Control Panel - Sound and set HDMI as default.


That's it :-)
Hope it works for you too.
Don't forget to set the speakers back as default after disconnecting.

Say "Thank you" 484

A few words of thanks would be greatly appreciated. Add comment

CCM 4399 users have said thank you to us this month

thank you. I too have the same problem. mine is a panasonic 26 inch LCD and I got HP laptop. Connected thru HDMI, there was no sound. Let me try ur solution. If it works, I will be more than happy. Thanks a lot
it worked but in my laptop I first went to control panel then sound like you said then it had a little tab on top it said playback and it had the name of my tv, I selected it and set as a default................well thankss :)
Thank you very very much
-
thanks it really worked for me
169
Thank you
Just right-click on the sound icon on the taskbar (by the time), click on the PlayBack tab, then Right-click on either HDMI or Speakerphones and select "Set as default" to switch between TV and PC speakers

Note: You might need to close and restart any applications like Media player, VLC, Mozilla etc. For instance, say you were listening to iTunes, then hooked your pc to your tv and followed the staps above, there'd be no sound coming from the iTunes cos it's still set on Speakers/Headphones. So you'd need to close it and restart it
does not work for me
130
Thank you
I dont know whether you guys have tried this but it works for me. Try :

control panel-device manager-system devices-high definition audio controller.

Enable it. In my case I have 2 high definition audio controller. Disabling one of it will disable the pc speaker & digital audio/spdif. Disabling the other will disable the ATI HDMI output with the tv icon. Enabling both will enable all sound playback device. You can actually open the sound playback device window and see the icon comes and goes as you play around enabling and disabling the audio controller.

Give it a try. Just sharing what works for me
52
Thank you
Hi, maybe you solved it already, but if not, I solved the problem with my Sony Bravia, it is not any HDMI port you have to use, in my case it was HDMI 4 plus the male-male jack from the laptop to the rear tv connection, so simple...
49
Thank you
I had the same trouble with my dell mini and there are some applications that use the default sound device and the easiest way around this is to right click my computer hit properties under the device tab click device manager and disable the non hdmi sound device by going to teh sound section and right clicking the device and hitting disable. Then if you need it back on just right click and enable, that is what worked for me.
25
Thank you
hi,

I got this solved I had this problem too, maybe you have solved it by now..I also have vista..had my PC through the LCD television..and went to control panel...then souund...then wehnt he box opens up you have 3 different options..the top one is speakers...make this as default..but this is the mistake I made..expecting it to wrok wihout restarting my PC...you have to either close your computer down after selecting this setting..or close down any sound thing like media player and start it again..it wont just automatically swtich..you have to close down any sound thing thats playing like Itunes..or media player..then it worked for me..I have a cable from my PC to the backl of the TV which says DVR and its labelled ..audio..it should work if you do that...I too thoguth you just change the sound seetings and that is it..you are better restarting but I notioced it still works without restarting if you close any sound cadget down and re open it..then it shoudl come through the speakers on your TV..good luck x
Restarting the programme works! Cheers!
25
Thank you
if you are using hdmi calbe just power down your monitor disconnect the cable, wait 5 sec and reconect. worked for me.
it worked for me thanks bro
10
Thank you
Use an analog monitor cable out the back of the pc into the analog pc jack in the TV. If you only have DVI out on your computer then use an adaptor to make the analog in on the back of the TV to work. Don't expect the audio to work using an DVI-HDMI cable. Once you have the analog cable installed you can run a wire from the green audio jack into the audio jack next to the analog input.
hi allan I ave read your threads and still no joy I have samsung lcd tv connected to my pc via dvi to hdmi. using an 3.5mm jack from green output to tv audio tryed all the phono inputs. I know it works because ive tested it through my headphones any help would be appreciated thank you in advance.
Hi all. I have tried most of what you said but nothing. Some of the things make no sence to me as I am no buff with pc's.Please can someone be so kind as to spell it out for me or talk laymen terms please.I have a 42" Sumsung 5 series,have to use hdmi to dvi.Picture is there but no sound.