Toshiba Latop Satellite C655-S5504

Closed
Shwak1982 Posts 3 Registration date Wednesday December 26, 2012 Status Member Last seen December 26, 2012 - Dec 26, 2012 at 11:54 PM
Shwak1982 Posts 3 Registration date Wednesday December 26, 2012 Status Member Last seen December 26, 2012 - Dec 26, 2012 at 11:57 PM
Hello,

I need help!

It has been almost a week and my Toshiba has the black screen of death! I have tried unplugging it, taking the battery out, everything.

Today, after days of not being on, I finally got to system restore. It took forever and then said it couldn't do the system restore. Then I tried factory default restore. It was in the second process and just shut down! Now it won't come on again!

There is a blink of a light under the keyboard part upon start-up. Nothing else responds. It is just a black screen. You can hear the fan running as well.

I am desperate here. I figured I would try this before I spend $80 on an attempt by the local repair guy.

2 replies

Shwak1982 Posts 3 Registration date Wednesday December 26, 2012 Status Member Last seen December 26, 2012
Dec 26, 2012 at 11:55 PM
omg. So I took the battery out. Restarted the computer literally 5 times. Once I got on here to write this, I closed the laptop. I just opened it up and it says "Setup is installing devices (percentage). wth
0
Shwak1982 Posts 3 Registration date Wednesday December 26, 2012 Status Member Last seen December 26, 2012
Dec 26, 2012 at 11:57 PM
It just shut off again and restarted itself . . . and the black screen is back.
0