Files missing even after removing the shortcut virus [Solved/Closed]

Posts
1
Registration date
Saturday April 13, 2013
Status
Member
Last seen
April 13, 2013
-
Hi,

I am using window 7, Dell Core i7.

Previously my external hardisk was infected by virus and it turned to shortcut.

I have tried all the method suggested, by unhiding the files, install and run software to disable autorun, as well as antimalware and even using cmd.exe.

Although most of the files recovered, but still got few important files remained missing.

Please help me in solving this problem!
See more 

4 replies

Best answer
approved by Ratnendra Ashok on Jan 29, 2019
55
Thank you
Hi,
  • Go to Command Prompt.
  • Change the directory to your external drive (say J:\)
  • Type J: (at the prompt)
  • Then, you'll see that the drive of operation has changed
  • Now, type
    attrib -s -h /s /d *.*
  • Open the drive in a new Window Explorer
  • Check for autorun.inf and remove it. (You could scan the drive to remove it)
  • Your folders now appear in one folder.
  • Open that folder to recover your data.


Thanks1

Say "Thank you" 55

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 5577 users have said thank you to us this month

Thanks mate... made my day.... finally life saving hack....
Thanks buddy
Superman, thanks.
great stuff!
thanks
working great
-
this helped me big time, thank you !!!!!!!!
10
Thank you
Thank you very much for the advice!
I had the shortcut virus on a stick, I cleaned it with Mcafee but the files were no longer visible, although the "properties" showed that the stick was 80% full (which was correct). I did what you said and it worked. However, for dummies (like myself!), it were (maybe) better if you said to type

attrib[space]-s[space]-h[space]/s[space]/d[space]*.*

Again, a big THANK YOU!
Posts
6498
Registration date
Sunday June 6, 2010
Status
Moderator, Security contributor
Last seen
December 30, 2015
1741
6
Thank you
Hello,

Try this 1

1) Click on Start --> In search bar, type control folders and press Enter.

"Folder Options" will be opened. Now click on the "View" tab.

2) Select the option "Show hidden files, folders and drives" and uncheck the

check box "Hide protected operating system files" --> Click on OK.

Now look for your files. Later undo the changes that your have made by following

the Step 1 and clicking on the "Restore Defaults" button.

3) If still the files are missing then try the recovery software "Recuva" without

making any changes to that drive and check if you able to find all those file in the

recovery. Click on the below hyperlink "Recuva" and download the file

Recuva

Good Luck
bro it work like a charm...thank you mate...
Thanks buddy. your r a geek.
thanks a lot ,,, man!!!!!!!
oh my god.. thanks a lot
thank you so much. It worked for me
0
Thank you
Thanks men I did work perfectly.