Excel and keyboard problems on a mac [Solved/Closed]

Report
-
 Amon -
Hello,
i am having a problem with my keyboard in Excel. Every few minutes when I am typing nothing shows up on Excel. If I save the excel file and then I can type for a few more minutes before nothing shows up in excel again. Any suggestions. I tried turning the computer off and on and changing keyboards. the same thing happens again after a short time.

Any suggestions?

Steve

12 replies

Here's what worked for me. :)

Close all excel files. Right click on the Excel Icon (located on the dock) and select "Quit"
21
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

thanks a lot.. it works on my problem..
Quitting excel work, but it doesn't solve the problem. see skoetter Nov 21, 2014 05:53AM above for the real fix.
Posts
1
Registration date
Friday November 21, 2014
Status
Member
Last seen
November 21, 2014

try going to System preferences, keyboard, shortcuts and un-select ''the way Tab moves focus". Solved my Excel for MAC problem.
That fixed my problem. thanks much. --Pam
Thank you. This solved my problem too.....
Thanks. This helped.
I'm having the same problems. We uninstalled and reinstalled Office, but it is still doing the same thing. Sometimes if I click in a different cell and go back it works - but most times not. Wish I had a solution.
I found what may be a solution at:
https://www.mac-forums.com/forums/macos-operating-system/82598-leopard-keyboard-freeze-3.html
The suggestion is to go to Preferences/Edit and uncheck Cut, Copy and Sort objects with cells. I don't know what the implications of doing this are, but will post again if it turns out to have unexpected consequences.
Actually, the problem persisted in Excel until I unchecked Preferences/ Edit/ Edit directly in cell. A bit of a pain because that means you can't modify ranges etc just by clicking on the cell with the formula.
Try Command+Option+return
Thanks. Solved my problem!
Command Option Return. Thank you! That did the trick for all cells.
This is not helping me. :-(
Yesterday I could type in like normal. 30 mins ago I could only type numbers. Now I can't type anything. Suggestions?
Yes, this is a real problem. It's a general problem with Microsoft Office for the Mac (terrible SW). A workaround that sometimes works is to flash in and out of the "Dashboard" by hitting F12 twice -- Excel usually recognizes the keystrokes after coming back from Dashboard.
I have had a similar problem with MS Office for Mac (Excel & Word, specifically). However, I have also had this problem with other non-Office software. I've found that just using the mouse to click on the desktop and then back in Excel will allow me to continue working. This is an annoying problem. I have considered reinstalling the OS, but have not yet had the time.
Posts
14
Registration date
Monday December 29, 2008
Status
Member
Last seen
June 18, 2009
9
hi,
this may not be because of the keyboard but rather the software.
try to repair it, or you may uninstall the software and reinstall it.
this should work.
Anyone having these problems with Excel 2008 for Mac? I'm considering purchasing. Any thoughts?
I use the Office 2008 and having the same problem. It's frozen without any signal of solution.
I am having the same problem. It is driving me crazy. I type a few letters and have to save before I can type anything else.
I have the same problem....
I will be entering data and suddenly I won't be able to type anything into a cell...
I click around for a few mins trying to get it to type and sometimes it will allow me to start typing again...
and then shortly will not allow me to type.

This is very frustrating...I have the same configuration details as you
Posts
1
Registration date
Monday February 10, 2014
Status
Member
Last seen
February 10, 2014

just restart your system and work it..
I am having this problem with Excel 2013 for the Mac. The only thing that works is to restart the computer which is not an acceptable solution. Can anyone help?

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!