Windows script host error [Solved/Closed]

-
Hello, I have huge malfunctioning of WINDOWS SCRIPT HOST ERROR. Every time I log on I get it as...."Google-".......in the status bar....i tried to delete the vbs file as suggested in one of the repair sytem ....however, it didn't work!!!

Please direct me as to what to do!
See more 

4 replies

Best answer
approved by Jean-François Pillou on Nov 30, 2018
68
Thank you
Don't Worry,

Actually windows script host is created by microsoft for running any types of scripts in startup mode...
you can disable Windows Script Host; this will prevent users from running any scripts (including VBScript and JScript scripts) that rely on WSH.

To disable Windows Script Host, create one of the following two registry entries (REG_DWORD) and set the value to 0 (you need to create the entry, because it does not exist by default). To disable WSH for a particular user, create this entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows Script Host\Settings\Enabled


Now...When enforced, the following message will be displayed any time a user attempts to run a WSH script:

Windows Script Host access is disabled on this machine. Contact your administrator for details.


This message box appear even if the user attempts to start the script from a batch file or using a designated script host (for example, by typing cscript.exe c:\scripts\myscript.vbs at the command prompt).

Problem is solved!

Say "Thank you" 68

A few words of thanks would be greatly appreciated. Add comment

CCM 6146 users have said thank you to us this month

U saved my ASS!! UR Great. It really worked. ThAnKs......
GREAT HELP

Thank you!
VISH Dec 23, 2008 3:02am GMT

You Rock Man Thanks of Lotssssss!!!!
The point HKEY_CURRENT_USER\Software\Microsoft\Windows Script Host\Settings\Enabled (change to 1)
7
Thank you
I'm running windows 7 and it work like this:

press start button
type msconfig.exe
under general click Selective Start-up
and then go to the Start Up tab
find the startup item(s) with a command of Wscript.exe
unchecked them and click apply.

click restart when restart selection prompts.

it worked on me I hope it works on you too^^
6
Thank you
Dear All,
I kept trying various things to get rid of the wscript error that didn't let me load my task manager or let me enter into the registry and it would.nt delete either. After various forums, I cracked the wscript.exe viruus error and its been a while now. Thought i'd come back and help a few who might have the same issue.
Hope you have a good antivirus installed to begin with. Login using safe mode (press F8 while computer starts loading) and once in safe mode, download 'security task manager' (available on google). Once it is installed, open it and end wscipt.exe from the current processes wherever you find it. As you end that, go to your windows search engine and search for wscript.exe. It will load each place that the virus is hidden (make sure you choose 'search hidden files too'. So as the search gives results, select al and hit shift+delete to permanently delete it. Do not fear, do it.
Then while in safe mode, run a complete system virus scan. restart your computer. You would have removed the virus off your computer. My brother works with norton, he was mighty impressed by my try and success.

Regards,
Aparna
Hi Aparna,
The procedure looks very promising. My problem is that I can not install the security task manager. After running it opens a black window with a crazy prompt in it appearing all over the window. Is it possible that the virus is blocking this as well?
I wold really like to get rid of this ...... . Could you help?

Thank you,
5
Thank you
This is the solution

Windows Registry Editor Version 5.00

;ENGLISH
;Windows Script Host
;Windows Script Host access is disabled on this machine. Contact your administrator for details.
;Source: http://technet.microsoft.com/en-us/library/ee198684.aspx
;Disabling: "Enabled"=dword:00000000

;TÜRKÇE
;Windows Kod Merkezi Eri?imi
;Windows Kod Merkezi eri?imi bu makineden devre d???. Ayr?nt?lar için yöneticinize ba?vurun
;Kaynak: http://technet.microsoft.com/en-us/library/ee198684.aspx
;Pasif hale getirmek için: "Enabled"=dword:00000000

;To enable WSH for a particular user
[HKEY_CURRENT_USER\Software\Microsoft\Windows Script Host\Settings]
"Enabled"=dword:00000001

;To enable WSH for all users of a particular computer
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Script Host\Settings]
"Enabled"=dword:00000001