My WD passport 1tb is not recognized [Closed]

Report
Posts
4
Registration date
Monday December 7, 2015
Status
Member
Last seen
December 7, 2015
-
Posts
4
Registration date
Monday December 7, 2015
Status
Member
Last seen
December 7, 2015
-
Hello,

I have WD passport 1tb, and suddenly it's not recognized. When I'm connecting it to my laptop the light is on and it makes the connection sound, but when I'm getting into My computer it's either not shown at all or I see something called Local disc E (which I usually don't have). When I'm trying to open the Local disc E, the process it not responding any more. When it shows the Local disc thing, it seemes like the computer is trying to upload somwthing- there's a green line on the comand line
I tryed to look for it on disc management, but when the passport is connected- it's not responsing as well. When I'm disconnecting it the disc managemnet starts to work. I tryed connecting it to other comuters- but the same it happening.

3 replies


Hello,

have you tried using a different USB Cable?

What is displayed in Disk Management?
Posts
4
Registration date
Monday December 7, 2015
Status
Member
Last seen
December 7, 2015

I'm looking for another cable because I don't have another one.
When My passport is conncted it just wont uoload anything- empty grey screen, saying on the bottom- connecting to virtual disk service... as I disconnect the passport, the disk management upload correctly.
I've attached a printscreen as an answer to the main topic
Posts
4
Registration date
Monday December 7, 2015
Status
Member
Last seen
December 7, 2015



on the left- when passport is connected.
on the right- when I disconnect the passport

Have you tried booting your PC in safe mode and seeing if it's displayed?
Posts
4
Registration date
Monday December 7, 2015
Status
Member
Last seen
December 7, 2015

I just did.
Acts the same :(

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!