Monitor goes to power save mode + GPU loud fan noise

Closed
XxXeNoNx Posts 2 Registration date Monday February 15, 2016 Status Member Last seen February 16, 2016 - Feb 15, 2016 at 03:59 PM
XxXeNoNx Posts 2 Registration date Monday February 15, 2016 Status Member Last seen February 16, 2016 - Feb 16, 2016 at 08:24 AM
Hey all recently im experiencing randomly this issue and i hope someone can help although i presume that one of these three hardware components is the coulprit:

GPU
MOBO
PSU

So anyways the problem started 5-6 days ago im not sure if the problem was the newer version of Crimson Edition AMD drivers 16.1 to be exact, although this happened on 15.11 before i upgraded to 16.1.
Anyways it happens randomly when im browsing through the net or watching movies, the screen just goes black and goes to power save mode and after few seconds my graphics card goes crazy, fans are always spinning on 100 %, i thought it was temperature problem but it wasnt. The temperature was always 25-30 celsius.
So during this time keyboard and mouse are working and sound is still playing but i cant do anything other than reset the pc...
There were a few days when i didnt had this problem at all, but it usually happens once or twice per day...
So this is pretty much it i do hope someone could help me out with suggestions here.
Thanks

PS
My rig is:
i5 4670
8 GB ram
Radeon R9 270x Toxic Boost 2gb GDDR 5
CX600 PSU
Asrock z87 Extreme 3 mobo

1 reply

xpcman Posts 19531 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,835
Feb 15, 2016 at 08:07 PM
I would start by reverting to the prior video drivers. I suspect the new driver is at fault. Sometimes generic drivers have problems when used with existing hardware. Usually drivers downloaded from the board manufacturer have a better chance of working without glitches.

Good luck
0
XxXeNoNx Posts 2 Registration date Monday February 15, 2016 Status Member Last seen February 16, 2016
Feb 16, 2016 at 08:24 AM
Its not integrated video card...its AMD r9 270x toxic but ok ill try to revert.

EDIT: I reverted from Crimson 16.1 to Catalyst 15.7 version so we will see how it goes.
If i get crash again ill just send my gpu to service this week.
0