Computer monitor wont recieve signal

lastbrethfyter Posts 1 Registration date Friday March 11, 2016 Status Member Last seen March 11, 2016 - Mar 11, 2016 at 12:15 AM
 Lastbrethfyter - Mar 14, 2016 at 02:20 PM
Hello, i have an Asus 970 aura gaming motherboard with an AMD FX 6300 6 core processor and an EVGA gtx 750 ti superclocked graphics card. i am looking for help. i just put all this together and i turned on my pc, all fans hds and processor started. though when i turn on my monitor it says (no signal) and the light turns yellow. i tried changing monitors, RAM, cables, reseating the graphics card and checking my system for dust. please help if you have any solutions.

i tried holding the power for 30sec-1min but nothing helped.

also my system runs windows 10


1 reply

BrianGreen Posts 1010 Registration date Saturday January 17, 2015 Status Moderator Last seen September 30, 2021 149
Mar 11, 2016 at 05:16 AM
Hi lastbrethfyter,

Have you connected all the power leads that you need to? There is always a 24 pin main power socket on motherboards. Some have an extra 4 pins that should be connected making what looks like a single socket of 28 pin socket. In addition, some motherboards have another power socket to help with providing enough power for some components of the motherboard. If present this should also be connected to the power supply. Finally most newer graphics cards have their own dedicated power connection which must also be connected to the power supply. If any of these are missing, then the symptoms yo describe could occur.

In your case, the card itself needs a 6 or 8 pin power supply (depending on the model), and the motherboard requires an 8 pin AND a 24 pin (Im surprised it isnt the 24 +4 version but if the +4 is there then it should be connected as well) power connection.

I hope this solves your problem. Please let me know how you get on.
Mar 14, 2016 at 02:20 PM
Hey, I was able to fix the problem. I took the motherboard out and found the RAM slot was so small that the RAM would not seat easily. But I have fixed the problem. Thanks