Metal Gear Solid PC GAmepad Problem [Solved/Closed]

Cuban Pete - Apr 19, 2009 at 09:45 AM - Latest reply:  Phatsnake
- Nov 27, 2011 at 12:15 AM
Hello,

I'm trying to play Metal Gear Solid on Pc with Dualshock 1/2 via Speed Link Connector.
Analog sticks won't work and the D-Pad seems to stuck, Snake just runs down and right.
These problems appear nowhere else, neither emulators, nor pc games. I already tried to
calibrate it otherwise, but there's no difference.
Any ideas?
See more 

7 replies

Best answer
The Impaler - Jun 28, 2009 at 09:56 PM
6
Thank you
Hey dude, are you still with that problem? I've just installed MGS 1 (PC version) and I noticed too that my gamepad didn't work well at all, even I had the same problem, Snake didn't stop running like an idiot, without pressing any key of my gamepad...

You've got to download a little program called JoyToKey, and then configure it depending on your gamepad. I've just tried it and it works perfect for me. There are some tutorials out there that shows you how to configure the program.

Also, I think there's no way to disable your gamepad in the game, so if you want it to work well, you must "unassign" your gampad keys to avoid Snake running... (go to Options -> Controller Options, there), it should look like this: http://img4.imageshack.us/img4/8881/mgsconfig.gif

I'd like to know if it worked for you, tell me if there's something wrong... Cheers!

Thank you, The Impaler 6

Something to say? Add comment

CCM has helped 1665 users this month

3
Thank you
It's all about NumLock !
That's the cure! You sir are brilliant! Make sure numlock is not pressed. Most keyboards have a light to indicate it. My gamepad wasn't working at all until I turned numlock off.
0
Thank you
Great! I'll try it asap.
Thanks so far.
0
Thank you
Configured everything like you said - "disabling" the controller was a bit tricky - but it still won't work.
The game seems to see through the disguise.
The Impaler - Jul 1, 2009 at 04:44 PM
0
Thank you
Well, that's kinda strange... It should work.
Remember not to quit JoyToKey, just keep it running, then launch the game... Maybe you didn't configure the program the right way...
If you still have problems with that, try Xpadder then, but I think is the same anyways...
0
Thank you
joytokey works perfectly for me