Toshiba c50-b laptop touchpad not working.

dylan59993 - May 16, 2017 at 03:20 AM
 Blocked Profile - May 16, 2017 at 04:52 PM

I have this Toshiba satellite c50-b laptop that has an issue with its touchpad. I can't seem to fix it, I've tried reinstalling the drivers that fit the model number, ive tried pressing all the keys to get it working such as 'Fn+F5 or Ctrl+F5 (or Fn + F9 or Ctrl+F9)' but nothing will work. I tried searching for the properties but still nothing. The laptop does not recognize that there is even a touchpad there. The device manager does not have nothing about a touchpad installed until i plug a external usb mouse than of course one mouse device pops up(the one i just plugged in, not touchpad). The wierd part is it randomly starts working after restarting like 15 times. It's like russian roulette i start the laptop up and there is like a 10% chance of it actually working. Any help would be greatful as many of the other responses on the other forums are just try pressing the function keys. Thanks! Please reply ASAP :D

1 response

Blocked Profile
May 16, 2017 at 04:52 PM
Ok it sounds like some system files might be corrupted. Try this:
get a cmd prompt and run SFC /scannow with an admin credentials. reboot, and let us know!